Lifx bindings stuck INITIALIZING forever

I’m trying to use the Lifx bindings but on the console they are stuck in Status=INITIALIZING

Here are my things…

lifx:colorlight:D073D5003FBE (Type=Thing, Status=INITIALIZING, Bridge=null)
lifx:colorlight:D073D5004280 (Type=Thing, Status=INITIALIZING, Bridge=null)
lifx:colorlight:D073D50066D2 (Type=Thing, Status=INITIALIZING, Bridge=null)
lifx:colorlight:D073D5006772 (Type=Thing, Status=INITIALIZING, Bridge=null)
lifx:colorlight:D073D5023BD6 (Type=Thing, Status=INITIALIZING, Bridge=null)

I have seen the same.
Could you please enter an issue at

@Kai sure! What kind of info should I include? Just my logs and the list of things?

Hm, I just tried to fix it today, but could not reproduce it anymore. All bulbs went ONLINE without a problem…
So before entering an issue, could you please retest with the latest version? If it still occurs, yes, it would be good to have some debug log attached to the issue (enable it by typing log:set DEBUG org.eclipse.smarthome.binding.lifx on the console).

@Kai I will but what I’ve noticed is it generally works when I first add them, it’s when I restart Openhab2 is when they get stuck in that state. If I delete them and readd them I normally can get them to be ONLINE again.

Right, but today I also had them going ONLINE after a restart…

@Kai weird, is this the latest nightly release? I’ll try upgrading and trying again when I get home.

Yes, latest nightly - or rather latest sources, because I ran if from my IDE (since I wanted to fix the bug). I don’t know, maybe the problem only occurs when running the distro and not from the IDE? I won’t have time to do further tests before next week…

@Kai I’ll try to provide some better debug information. I’m actually a developer myself so I’d be interested in knowing how I could track this issue down and fix it.