Lightwave RF

Hi guys, first off thanks to the developers for a job well done, Im struggling to get the lightwave rf binding configured for device ID and room ID, I have been using wire shark but unable to find were I locate this info, I have demo item etc setup on site map… just at Item files now…any helps appreciated

I don’t use that binding, but it looks like it is all explained very well in the docs:

To configure items, you first need to add the devices using the LightwaveRF App on iPhone or Android.

To do this, sniff your network using something like wireshark whilst sending commands using the smartphone application. You should see messages like “100,!R1D3F1”

This means that lightwave switch/dimmer roomId = “1” and device id = “1”

For thermostats you will see a message like “100,!R1F*r” this means the room id = “1”. There will then be a return message that looks like JSON with the following in it… “serial”:”123DEF” this means the serial id = “123DEF”.

Yeah thanks I followed that, done everything but I am struggling to see were I find the commands within wireshark, I have pressed commands within app and cannot seem to find which line or section these commands will be listed or displayed… I have tried filtering by ip address and ports etc, but to no avail…

I can’t test because I don’t have any lightwave products, but I’m pretty sure you will find answers here:

yeah I got commands thanks, the only problem is cant seem to get the link to flash to accept registration for openhab, once i drop the addon file into openhabian


nothing seems to happen, its like the file wont execute is there something else im missing.

Did you configure your lightwaverf.cfg?

This binding can be configured in the file services/lightwaverf.cfg

Thanks, Yeah I did that but I think i may have a binding issue do I still need to do the feature:install openhab-runtime-compat1x on openhabian if so I tried running the command it results in error command not found.

I went into openhab console and installed the 1xbinding using command

Feature: Install openhab-runtime-compat1x

But Light doesnt flash on hub to register openhab

Ahhh, you are right, I did not see that this binding is NOT part of the openHAB distribution yet.

Yes, you need to install the compatibility layer

You have to do this on the karaf console, not the operating system console:

Note that the password is different from a standard openHAB2 installation in openHABian:

Ready for more? Connect to your Raspberry Pi SSH console using the username openhabian and password openhabian. You will see the following welcome screen:

It is not good practice in a forum to double post:

Means: I’m out.