LightwaveRF - New LightwaveRF Binding

Hi Dave. Ok, will do. Sorry for delayed response, only just seen this for some reason. Will get on it and let you know…

1 Like

Running through the steps now. Looking to set the logging level to trace in the Karaf console with a command similar to


but I’m afraid I don’t know what to use as a log category? i.e. what do I need to use for the Log Category

log:set TRACE org.openhab.binding.lightwaverf

Hi Dave,

To update on the steps you suggested…

  1. Removing things:- I wasn’t able to remove the the account thing - so I disabled it. Also, the Dimmers stayed in ‘removing’ state
  2. I removed the Jar
  3. I stopped OpenHab
  4. I cleared the cache
  5. I restarted openhab and replaced the Jar
  6. I noted that the Dimmer things were still in UI showing as as disabled - I tried to delete them once more and had to ‘force remove’ them
  7. Openhab discovered the account - it went online
  8. Openhab discovered the LinkPlus device - it went online
  9. Openhab discovered three dimmers:-
    1 x D21 device (this is correct and is a single dimmer that has always been working fine before I engaged in this thread)
    2 x D11 - Gen 1 1 Way Dimmers (not alligned to physcial setup)
    However I only have 2 physical devices:-
    1 x D21 Dimmer (correctly discovered)
    1 x D12 Dimmer (The Gen 1 2 Way Dimmer that I’m trying to get to work)

So from discovery, seems to be the same situation as before, the single physical D12 is being incorrectly discovered as 2 x D11. However, I went ahead and added all three things and linked items to check the result.

Switch  Toggle_Lightwave_Spare_Room  "Spare Room Light Switch"  <dimmablelight> (Random_Lights, All_Lights)   { channel="lightwaverf:d21:buckell:5e4473744690cd6d270525a17315xxxxxxxx:1#switch" }
Switch  Toggle_Lightwave_Lounge_Ceiling_Front  "Lounge Ceiling Light Switch Front"  <dimmablelight> (Random_Lights, All_Lights)   { channel="lightwaverf:d11:buckell:5e4473744690cd6d270525a13315xxxxxxxx:1#switch" }
Switch  Toggle_Lightwave_Lounge_Ceiling_Rear   "Lounge Ceiling Light Switch Rear"   <dimmablelight> (Random_Lights, All_Lights)   { channel="lightwaverf:d11:buckell:5e4473744690cd6d270525a12315xxxxxxxx:1#switch" }

And I added these items to my sitemap.

And… Both Dimmers / all three switches work as expected!

So thank you for your hard work - I have a working system
I guess the remaining puzzle (at least from my perspective) is that the binding is finding 2xD11, not 1xD12…

As an aside, whilst I didn’t enable log tracing (didn’t spot Alex Pearce’s helpful post above until too late) I saw this in the logs:-

2021-08-25 15:59:44.716 [ERROR] [ernal.LightwaverfSmartCommandManager] - Ok message not received for transaction: 56, for Device: 5e4473744690cd6d270525a1-3-315xxxxxxx+x, retrying again. Retry count 2
2021-08-25 15:59:45.957 [ERROR] [ernal.LightwaverfSmartCommandManager] -  Cannot process update, message wasnt present
2021-08-25 15:59:45.960 [WARN ] [ernal.LightwaverfSmartCommandManager] - Command response for  wasnt processed as there is no listener present

Shout if there is more I can do to help (happy to run process again and do the trace logs this time if you’d like)


I must be missing something silly, will take a look when I get 5. :+1:

Not been on my system for a while but I notice my energy monitor’s been failing for what looks like a few weeks with this error:

2021-09-02 15:12:07.947 [WARN ] [htwaverf.internal.utils.WsConnection] - LightwaveRF - Error handling command: {“version”:1,“senderId”:“1.ip=10=192=21=45=24475”,“transactionId”:1001386,“direction”:“notification”,“class”:“feature”,“operation”:“event”,“items”:[{“payload”:{“time”:1630591927921,“featureId”:“5a6a3fbfc211836b17f98f26-148-3157328472+0”,“deviceId”:36,“type”:“rssi”,“channel”:0,“writable”:false,“stateless”:false,“virtual”:false,“value”:-72,“status”:“ok”},“success”:true,“itemId”:2957}]}

It’s working ok and returning values into the Lightwave app, just OH isn’t getting them for some reason.

Anyone else having trouble?

I am missing something, but I can’t figure out what.
I have generation one link. I am using 3.2.0-smapshot_3.11 binding, I have added Connect Series WIFI link and provided IP address of hub.
Then I added Connect series - 1 way switch, set bridge to the above link. set room to 4 and device id to 1. It seems that binding is sending command with missing room and device numbers, logs show this:

21:43:34.979 [INFO ] [ndler.LightwaverfConnectSwitchHandler] - Sending Command:,!RDF0 from device:
21:43:34.980 [INFO ] [ctions.LightwaverfConnectSenderThread] - added command to queue: 201,!RDF0

When I add dimmer - it sends command that looks better (at least has room and devce id) dimming doesnt work:
21:46:16.767 [INFO ] [ctions.LightwaverfConnectSenderThread] - added command to queue: 200,!R1D3FdP12

What am I missing?

Did it sort itself out?
What version you running now?
Not sure if anything has changed since LW introduced their new bits and bobs.

Gen1 not fully integrated atm as lack of testers. If you are willing to work with me then we can get it all integrated.

@delid4ve Thanks for getting back. Sorry for the delay in replying, had a water leak from my combi boiler upstairs coming down into the kitchen through the ceiling…

No, that same error still clocking up in the log. It has to be the energy monitor as the values from it aren’t coming through into OpenHAB but the monitor is working and I can read the values from it in the LWRF app. Like you I suspect LWRF changed something along the way with all of their recent innovations.

With regard to versions I’m still running the one from ages ago, last time we spoke, and still on OH2. It’s been working fine apart from this so I saw no reason to change things.

How do you recommend I try to troubleshoot this?

Also, in response to your other thread I’ve got Gen1 plug-in sockets, Gen1 relays and the Gen1 energy monitor so if you need help with testing on those I’ll be happy to help.

Will happily help. Have relays, dimmers and energy monitor.

Where do we start?

I’ve finally remembered to check mine and it died on the 23rd August which looks like it ties in with yours

@delid4ve what do you need from us to investigate, I’m running

Edit: not sure my app is seeing updates either though
Edit2: so my issue was fixed by replacing the batteries in my monitor :joy:

Thanks for checking.
Replaced the batteries in mine too. Its numbers are showing up in the Lightwave app ok but OpenHAB reports them all as undefined and keeps throwing that error

I have noticed that some of my devices aren’t working, others are though (all sockets), just not had a chance to look. Bear with me :+1:

No problem. You’re a busy man doing this for free and we appreciate that.
Here’s a little more to go on.

2021-09-25 13:20:02.572 [WARN ] [htwaverf.internal.utils.WsConnection] - LightwaveRF - Error handling command: {"version":1,"senderId":"1.ip=10=192=20=183*eu=west=1*compute*internal=85611","transactionId":15221103,"direction":"notification","class":"feature","operation":"event","items":[{"payload":{"time":1632572402550,"featureId":"5a6a3fbfc211836b17f98f26-146-3157328472+0","deviceId":36,"type":"power","channel":0,"writable":false,"stateless":false,"virtual":false,"value":2224,"status":"ok"},"success":true,"itemId":28071}]}

2021-09-25 13:20:02.572 [WARN ] [htwaverf.internal.utils.WsConnection] - LightwaveRF - Error handling command: {"version":1,"senderId":"1.ip=10=192=20=183*eu=west=1*compute*internal=85611","transactionId":15221104,"direction":"notification","class":"feature","operation":"event","items":[{"payload":{"time":1632572402550,"featureId":"5a6a3fbfc211836b17f98f26-147-3157328472+0","deviceId":36,"type":"energy","channel":0,"writable":false,"stateless":false,"virtual":false,"value":446379,"status":"ok"},"success":true,"itemId":28072}]}

2021-09-25 13:20:02.575 [WARN ] [htwaverf.internal.utils.WsConnection] - LightwaveRF - Error handling command: {"version":1,"senderId":"1.ip=10=192=20=183*eu=west=1*compute*internal=85611","transactionId":15221105,"direction":"notification","class":"feature","operation":"event","items":[{"payload":{"time":1632572402550,"featureId":"5a6a3fbfc211836b17f98f26-148-3157328472+0","deviceId":36,"type":"rssi","channel":0,"writable":false,"stateless":false,"virtual":false,"value":-111,"status":"ok"},"success":true,"itemId":28073}]}

2021-09-25 13:20:02.576 [WARN ] [htwaverf.internal.utils.WsConnection] - LightwaveRF - Error handling command: {"version":1,"senderId":"1.ip=10=192=20=183*eu=west=1*compute*internal=85611","transactionId":15221106,"direction":"notification","class":"feature","operation":"event","items":[{"payload":{"time":1632572402550,"featureId":"5a6a3fbfc211836b17f98f26-148-3157328472+0","deviceId":36,"type":"rssi","channel":0,"writable":false,"stateless":false,"virtual":false,"value":-75,"status":"ok"},"success":true,"itemId":28074}]}

2021-09-25 13:20:17.673 [WARN ] [htwaverf.internal.utils.WsConnection] - LightwaveRF - Error handling command: {"version":1,"senderId":"1.ip=10=192=20=183*eu=west=1*compute*internal=85611","transactionId":15222223,"direction":"notification","class":"feature","operation":"event","items":[{"payload":{"time":1632572417651,"featureId":"5a6a3fbfc211836b17f98f26-146-3157328472+0","deviceId":36,"type":"power","channel":0,"writable":false,"stateless":false,"virtual":false,"value":1202,"status":"ok"},"success":true,"itemId":28075}]}

2021-09-25 13:20:17.677 [WARN ] [htwaverf.internal.utils.WsConnection] - LightwaveRF - Error handling command: {"version":1,"senderId":"1.ip=10=192=20=183*eu=west=1*compute*internal=85611","transactionId":15222225,"direction":"notification","class":"feature","operation":"event","items":[{"payload":{"time":1632572417651,"featureId":"5a6a3fbfc211836b17f98f26-148-3157328472+0","deviceId":36,"type":"rssi","channel":0,"writable":false,"stateless":false,"virtual":false,"value":-76,"status":"ok"},"success":true,"itemId":28077}]}

2021-09-25 13:20:17.675 [WARN ] [htwaverf.internal.utils.WsConnection] - LightwaveRF - Error handling command: {"version":1,"senderId":"1.ip=10=192=20=183*eu=west=1*compute*internal=85611","transactionId":15222224,"direction":"notification","class":"feature","operation":"event","items":[{"payload":{"time":1632572417651,"featureId":"5a6a3fbfc211836b17f98f26-147-3157328472+0","deviceId":36,"type":"energy","channel":0,"writable":false,"stateless":false,"virtual":false,"value":446384,"status":"ok"},"success":true,"itemId":28076}]}

You can tell these errors are coming from the enegry monitor because one of the values being returned is ‘rssi’.

Also from the error message it looks like the binding is receiving the power, energy and rssi values from LWRF okay, but there’s perhaps something odd in them, or in the format of the return, that’s throwing an error and the binding can’t process them. That would explain why the values coming back are here in these error messages but are showing as undefinied in Open HAB.

Going to be pretty busy the next few days, but If I get chance I’m going to put the binding into debug and see if that gives any additional insight.

Not seen this before - can’t remember how I handle the json from memory but if it’s in a predefined class then it’s a problem…


And I’ve no idea what it is either, except that the query response from the LWRF servers seems to include it now for some reason

I’ll jump on this hopefully next week. Been rather busy with work and crypto :+1:

Happy to test Gen 1s
House full of light switches and no way to control them right now. (1, 2, 3 and 4 way dimmers) plus some sockets

This is stopping me shifting my home over to OH 3

I have just decided to setup a new openhab instance running v3 - I have loads of Gen 1 light switches that I can test once I get my head around the new setup.