Like many others, "Sitemap 'demo' could not be found"

I’ve done two installations on a raspberry pi. One following the openhab tutorial, and another using this link:


However, in both cases, after loading the demo configuration, I still get a sitemap not found error. My my configurations folder contains these files:


db4o.persist exec.persist logging.persist rrd4j.persist



demo.sitemap test.sitemap

What setting am I missing? the two files in sitemaps are owned by openhab:openhab

3rd party tutorials may have many useful tips, but they may also offer outdated instructions or inject problem-inducing diversions. This is the official way to install openHAB 1.8.0 on Linux or OSX, if you are using either of those operating systems.

Aside from that, if you enter the URL


what do you get? What specifically appears in the logs?

Thanks Watou,

I will do a fresh restore and reinstall of the Pi and follow that install guide.

I had tried the openhab install from the front page six months ago, and gave up trying to deal with this error.
I tried again yesterday and ran into the same thing.
I found that comprehensive raspberry pi install, and ended up in the same place. However, I think it was a mistake I made copying files over SMB, as the config file had disappeared. The mac was giving lots of finder copy errors.