Limit=2000' failed: Not Found

2.5.x here,
update org.openhab.binding.amazonechocontrol

fixed it as already said.
Thank you very much for your work.
BaseUrl should be in a config file as Amazon changes url often but I’m fine.

It was not a problem of the baseURL.

1 Like

Hi, should I write it in the terminal via ssh?

Thank you

Don’t bother, link is dead, but you would do it in karaf console.

I have done the update, but the issue now comes back.
2021-02-18 10:17:38.681 [ERROR] [nal.common.AbstractInvocationHandler] - An error occurred while calling method ‘ThingHandler.handleCommand()’ on ‘org.openhab.binding.amazonechocontrol.internal.handler.EchoHandler@665c7f’: GET url ‘’ failed: Not Found

If that URL is requested, it‘s the „old“ version.

i updated again… and now:
Thing ‘amazonechocontrol:account:6c171fb8’ changed from UNINITIALIZED to UNINITIALIZED (HANDLER_MISSING_ERROR)

openhab> bundle:list 240
START LEVEL 100 , List Threshold: 50
ID │ State │ Lvl │ Version │ Name
240 │ Active │ 80 │ │ mvn:org.openhab.addons.bundles/org.openhab.binding.amazonechocontrol/3.0.1

Could it be that you have two bundles running now?

openhab> bundle:list | grep -i ama
216 x Active x 80 x 3.0.1 x openHAB Add-ons :: Bundles :: Amazon Echo Control Binding
it is now the old one :frowning:
I have cleared the cache and rebooted, and the “old” Binding is active.

Yes. After clearing the cache you get the distribution Version.

ok, thanks for the hint. But after update to:
update org.openhab.binding.amazonechocontrol

i cannot access the amazonechocontrol
and it says

Thing ‘amazonechocontrol:account:6c171fb8’ changed from UNINITIALIZED to UNINITIALIZED (HANDLER_MISSING_ERROR)

But that snapshot JAR isn’t even available anymore, if I’m not mistaken. Try going to with your browser and it says no longer available.

That may explain, why nothing worked after the update.
Are there any suggestions to resolve the issue?
[ERROR] [nal.common.AbstractInvocationHandler] - An error occurred while calling method ‘ThingHandler.handleCommand()’ on ‘org.openhab.binding.amazonechocontrol.internal.handler.EchoHandler@1921ebf’: GET url ‘’ failed: Not Found

Is there an updated download link? That one doesn’t work anymore :frowning:

1 Like

Weird, extracted the JAR from " 3.1.0~S2222/", placed it into the addons-folder, but still have the same error. :flushed:

Index of openhab-linuxpkg/pool/main/3.1.0~S2217 try this

did you check which binding is the active one ?
in the openhab karaf console run:
bundle:list | grep -i amazon

1 Like

Thank you, stopped the old one and activated the 3.1.0 one and now it works.

1 Like

I downloaded the jar file to the addons folder.
How do I activate it?