Linking (ln -s) /etc/openhab2


I just reinstalled openhabian 1.4 and tried to use my (previously working) config by symbolic linking /etc/openhab2 to my cloned git-repo ~/Openhab/etc/openhab2.

I tried different ways of symbolic linking using ‘ln -s’ (including 'chown’ing to openhab:opanhabian), but still openhab complains for any of the /etc/openhab2/* folders:

[.core.internal.folder.FolderObserver] - Directory 'things' does not exist in '/etc/openhab2'. Please check your configuration settings!

Is it possible to link the config directory?
If so, what am I doing wrong?
If not, how can I change the config-folder from /etc/openhab2 to another directory?


Random thought-could it be mapping to openhab2 instead of openhab2/ or vice versa?

Thanks for the hint, If I got you right, it is still failing with both:
ln -s /home/openhabian/Openhab/etc/openhab2/ /etc/openhab2
ln -s /home/openhabian/Openhab/etc/openhab2 /etc/openhab2

But I recognized that the original folder is marked with an attribute ‘plus’: drwxrwxr-x+

lrwxrwxrwx   1 openhab openhabian    37 Mär  4 00:55 openhab2 -> /home/openhabian/Openhab/etc/openhab2
drwxrwxr-x  13 openhab openhabian  4096 Mär  4 00:27 openhab2.copied
drwxrwxr-x+ 13 openhab openhabian  4096 Mär  2 23:49 openhab2.old

What does that ‘+’ mean?

OK, found it.
I did not recognize that the ~/Openhab folder was created with rights 700.