Lirc doesn't run automatically after the boot

i have a problem with the LIRC.
I control my tv with LIRC but averytime that i reboot the Rasberry i have to start LIRC.
Is there a way to start LIRC automatically on every reboot of the raspberry?

Have a lookt at the description of the lirc binding . If your OS is systemd based you can follow the description under the headline “Supported Things”.

i tried but i have not the file /usr/lib/systemd/system/lirc.service
Maybe the path is wrong

How did you install lirc ? How do you start lirc manually ?

but LIRC works but i have to lunch it by the command
sudo /etc/init.d/lircd start
it doesn’t start automatically
Maybe there is a config file to modify to start automatically

this is already the file that needs to be used during system boot.
please use the command

find /etc -name "*lirc*"

to check if a link to the related boot levels is established.
There should be links in /etc/rc*.d/ pointing to /etc/init.d/lircd. If that is not the case try to run

update-rc.d lirc defaults 20

to create the links.

This is my situation

The message/error “could not assign address to socket” normally means that the port that is used in the lirc configuration / startup file is in use already.

Check the configuration / startup file which port is being used by lircd.
Then execute

lsof -p :port

replace “port” with the port number that is used in the configuration file.
As a result the process that uses the port will be shown.
It’s either an other service or the lirc daemon is already running.

it is not the problems. That message of error is because i stopped LIRC by the command “sudo /etc/init.d/lircd stop”
I explain you:
I use normally LIRC and it works but if i reboot the rasberry then i have to activate LIRC by the command “sudo /etc/init.d/lircd start”.
The problem is that i’d like LIRC start automatically when i reboot the rasberry.

I tried to do so:
Sudo nano /etc/rc.local
And into the file i inserted the command to start lirc: sudo /etc/input.d/lircd start
Then i reboot all by the command sudo reboot but again if i want lirc starts i have to digit the command to start lirc (sudo /etc/input.d/lircd start)
How do you do it?

help me pls

How did you install lirc ( e.g. via package manager ) or from source ( e.g. github ) ?


From which location on github / which url ?
Is there any logfile with lirc in it’s name in directory /var/log/ ( ls /var/log/lirc ) ?
Is there any entry in /var/log/syslog that contains the string lirc ( sudo grep -i lirc /var/log/syslog ) ?

From which location on github / which url ?

I don’t remember

Is there any logfile with lirc in it’s name in directory /var/log/ ( ls /var/log/ lirc ) ?

Is there any entry in /var/log/syslog that contains the string lirc ( sudo grep -i lirc /var/log/syslog ) ?


Google is your friend. Please check the following tutorial, as this is not an openHAB or openHABian related issue.

You wrote that there are entries that are related to lirc in syslog. What is the content ? What is the message of these entries ?

Now i again digit the code "sudo grep -i lirc /var/log/syslog but i have nothing.
Maybe because yestarday i lanched lirc and today no

What do get back for ( do not manually start the service )

sysv-rc-conf --list | grep -i lirc


systemctl list-units --type service --all | grep -i lirc

i have this: