Locations card: sub equipment not showing?

Hello all,

My kitchen has a window and that window has a rollershutter and a open/close sensor. So I defined the window to be an equipment with as location “kitchen”. Then defined the sensor as a point Openstate and the rollershutter as an equipment that is part of the window:

I would expect the rollershutter to appear in the default locations cards in the kitchen as a sub equipment of the window but that’s not the case:

Is this normal?

I’ve been playing around with the settings and I could of course mark the rollershutter as a point of type ‘Control’ and then it does appear. But then it would not appear in the equipment card “Blinds and rollershutters”. I could also add the location group directly to the sub equipment but then the rollershutters appears in the locations card as a separate equipment.

First reload the page to make sure changes made are being picked up. Next, according to the screen shot of your model “Gordjin keuken” has no semantically tagged members. I can see that because there is no little triangle next to it to open it up to see it’s members. So either your rollershutter is not properly tagged with a Point tag, or it’s not a member of the equipment Group.

The cards on the Overview tabs will not show equipment that do not have any Points.

Thank you Rich for your very fast response! In my example above, my rollershutter item is directly tagged as the Equipment of type “Blinds”. So it has no need for points and thus would not show up in the overview tabs as you mention (I wasn’t aware of that filter).

I have added an extra equipment group “Gordijn” in between the rollershutter item and the Window equipment:


But it still doesn’t show up in the overview card.

I come from the time that Openhab was mainly controlled with files so I have my semantics also in files. (I have way to many things/items to transform everything into GUI based control :().

The relevant lines:

// Equipments:
Group gKitchen "Keuken" <kitchen> (gGroundFloor) ["Kitchen"]
Group gKitchenWindow "Keukenraam" <window> (gKitchen) ["Window"]
Group gKitchenWindowBlinds "Gordijn" <blinds> (gKitchenWindow) ["Blinds"]

// The point:
Rollershutter KitchenBlinds "Gordijn keuken" (InnerBlinds, InnerBlindsGroundFloor, gKitchenWindowBlinds) ["Control", "Opening"] { ga="Blinds" }

This could be part of the problem. There is no event generated when you modify an Item’s tags and Group membership. Are you reloading the whole webpage every time you modify the .items file?

I personally do not recommend trying to implement the semantic model through .items files. It’s just way too much work and way too error prone.

I understand. I do a control+f5 refresh (multiple presses) to be sure to reload the pages properly. And if I could easily change everything in UI based management then I would gladly do this. Offtopic: I have about 150 things from a modbus binding and another 100 from mqtt. In total 742 items… And two very small kids :slight_smile:

On topic again, I have just setup a test environment (long live docker) to see if a UI based setup would result in a different behavior.

So I now have this model:

And after thoroughly refreshing, I still end up with the same problem in the overview cards:

“Create Equipment from Thing” is your friend.

Alternatively under Developer Tools (and elsewhere) there is “Add Items from textual definition”.

Either one can get your Items imported or recreated in minutes. When using “Create Equipment from Thing” it’s easier to situate your Items into the semantic model.

All I can offer now is to file an issue. I don’t know why it’s not showing, unless somehow you’ve managed to use tags that are not supported.

Yes I’ve tried several times to move everything to GUI. I’ll probably try again soon :slight_smile:

I’ve just scrolled through the issue list on github and found this issue:
Consider sub-equipment for glance badges in model cards · Issue #749 · openhab/openhab-webui (github.com)

The main focus is on the badges but at the end of the descriptions it’s clear that the sub equipments are also not shown for the topic starter. I’ll add my last example to that issue to clarify as well.

Thanks for your help Rich

1 Like

FYI: I had started the migration from file managed to UI managed things/items/scripts after my last post (4hr ago). For the simple part, the items, I used the UI import function that’s available. For the things and scripts I used the API to first export a json list of objects, save it to file, remove the things/rules files and import the things/rules again using the runner in Postman. I had some bumps in the road here and there but nothing that some good old regex couldn’t fix. Not exactly for the faint of hearted. I hope my WAF will not take a dive tomorrow.

As for the bug that this topic is about, I think I’m going to mark the rollershutter as a Control point for the window. I will not have a list of equipments of type “Blinds” but so be it.