Log error

hi, who can tell me what this error means?

2021-05-21 20:37:10.368 [WARN ] [.MqttBrokerConnectionServiceInstance] - MqttBroker connection configuration faulty: ID segment ‘’ contains invalid characters. Each segment of the ID must match the pattern [\w-]*.


That is not a value IP address. You’ve configured your MQTT Broker Thing incorrectly. You need to remove that :s from the end of the IP address.

but where did I go wrong?

In the config…

You’ve posted no details so how can we answer?

You have an MQTT Broker Thing configure in some way. You entered “” as the hostname/IP address. You need to enter “” instead.

things all have the right ip without “s”, how can I see where the error is?
what should i send as details?

  • What version of OH?
  • How did you install it?
  • What operating system?
  • How did you configure the Thing, text files or the UI?
  • The actual Thing configuration in question (if in the UI, click on the code tab and post that, not screen shots).

Think a little about it. You have a configuration problem. We don’t even know how it’s configured, let alone the actual config. We are not psychic.

the version is 3.0.2
I installed it on the raspberry
I created the thing from the user interface

UID: mqtt: topic: 87204f0158: 4f50933253
tag: Corridor Light
thingTypeUID: mqtt: topic
configuration: {}
bridgeUID: mqtt: broker: 87204f0158
Location: Corridor
- id: Chlucecorridor
channelTypeUID: mqtt: switch
tag: Corridor Light
Description: “”
commandTopic: cmnd / T1 / POWER1
stateTopic: stat / T1 / POWER1

That’s a Generic MQTT Thing. We need the MQTT Broker Thing.


UID: mqtt:broker:d11546c87c
label: MQTT Broker
thingTypeUID: mqtt:broker
lwtQos: 0
publickeypin: true
keepAlive: 60
clientid: 1518d303-9376-45f3-8c4c-ad165d223478
qos: 0
reconnectTime: 60000
secure: false
certificatepin: true
lwtRetain: true
enableDiscovery: true

OK, now go to Developer Tools and the API Explorer. Click on “things” and “Gets a thing by UID.” Click “try it out” and put mqtt:broker:d11546c87c in for the thingUID filed.

Paste the JSON that gets returned. Please use code fences for all code and logs.

code goes here
  "label": "string",
  "bridgeUID": "string",
  "configuration": {
    "additionalProp1": {},
    "additionalProp2": {},
    "additionalProp3": {}
  "properties": {
    "additionalProp1": "string",
    "additionalProp2": "string",
    "additionalProp3": "string"
  "UID": "string",
  "thingTypeUID": "string",
  "channels": [
      "uid": "string",
      "id": "string",
      "channelTypeUID": "string",
      "itemType": "string",
      "kind": "string",
      "label": "string",
      "description": "string",
      "defaultTags": [
      "properties": {
        "additionalProp1": "string",
        "additionalProp2": "string",
        "additionalProp3": "string"
      "configuration": {
        "additionalProp1": {},
        "additionalProp2": {},
        "additionalProp3": {}
      "autoUpdatePolicy": "string"
  "location": "string"



  1. Click on “Try it out”
  2. Paste in the UID of the Thing.
  3. Click on “Execute”
  4. Paste in the JSON under “Server reponse”

You’d normally only have one MQTT broker Bridge Thing.
If that one doesn’t have the unwanted “s” in its IP, we might guess thee’s another Thing.

People often accidentally configure a System Broker Thing as well, which you don’t want at all, so have a good look around to see what you’ve got.

  "statusInfo": {
    "status": "ONLINE",
    "statusDetail": "NONE"
  "editable": true,
  "label": "MQTT Broker",
  "configuration": {
    "lwtQos": 0,
    "publickeypin": true,
    "keepAlive": 60,
    "clientid": "1518d303-9376-45f3-8c4c-ad165d223478",
    "qos": 0,
    "reconnectTime": 60000,
    "host": "",
    "secure": false,
    "certificatepin": true,
    "lwtRetain": true,
    "enableDiscovery": true
  "properties": {},
  "UID": "mqtt:broker:d11546c87c",
  "thingTypeUID": "mqtt:broker",
  "channels": []

OK, this broker is OK. Do you have any other MQTT Broker Things? As rossko57 suggests, did you configure the System Broker? The error is not coming from here.

ok thanks

no, only this

Then there really is nothing else we can offer. I’d try to delete the existing Broker Thing and recreate it. If that doesn’t work then there is a rogue MQTT Broker configuration somewhere in your settings.

The :s implies a file that was edited with vi/vim and someone forgot to press escape before typing :s to save the file. Are you certain you don’t have any .things files?

yes i am sure, thank you for the help