Logging empty and stopped

  • Platform information:
    • Hardware: CPUArchitecture/RAM/storage OrangePI
    • OS: what OS is used and which version Dietpi linux
    • Java Runtime Environment: which java platform is used and what version
    • openHAB version: openHAB 2.2.0 Build #1140
  • Issue of the topic: please be detailed explaining your issue
  • Please post configurations (if applicable):
    • Items configuration related to the issue
    • Sitemap configuration related to the issue
    • Rules code related to the issue
    • Services configuration related to the issue
  • If logs where generated please post these here using code fences:

Hello, since about the start of this month, logging output is completely empty.

I’ve checked the ownership of the files in linux ls -l and openhab is the owner

i’ve tried looking in karaf with log:tail and nothing either.
log:get shows that there should be info level debug info.

Where should i start to attack this issue… any suggestions please!!

If OH is up and running correctly then my first guess is that your SD card is failing or you have edited the logging config in such a way as to accidentally turn off the logging to the file.

If you have updated from a stable version (2.0)or an older snapshot to a newer snapshot version and followed one of the guides posted you may need to copy back in the new logging file.

I ran into this exact issue after upgrading to a newer snapshot which included the new logger.


1 Like

Hi @kidsquid , I think that is exactly what has happened to me. Could you
elaborate or point me towards more info or steps that I need to take?

Thanks. Also thanks @rlkoshak for reply.

This is the post that helped me get back on track…

Great, that helped me too. thanks for the pointer!