Logicsoft ZCH5010 wall switch - working

Had some issues with some ZHC5010 wall switches I picked up some days ago. They included fine, but as they are not in the database, I was not able to set any association groups through habmin.
In order to receive useful notifications on key press (which is rather a convenient feature in a wall switch), I had to include my zway in the association group for the switch_binary command class.
I tried to power up the way server and use the expert UI to do this. no joy. Even though the necessary feature is there, it simply didn’t work.

But then I checked the zway JSON API, and found out I could add the needed multi channel association group node there simply through a browser, and it worked. bingo. I am now able to receive switch_binary command classes.

Below is how to do this:



  • devices[21] is the node id of the ZHC5010
  • instances[4] is the logic device (button #), in this case button 4
  • CommandClasse[142] is the command class ID for Multi Channel Association (see the API)
  • Set(4,1,4) means Group 4, Node 1 and instance 4

The last instance number is important, this means the event will be received as endpoint 4.

In items, the switch can then be configured as

Switch My_Switch_4 “Switch 4” {zwave=“21:4:command=switch_binary”}

This needs to be repeated for all 4 switches on the unit


Can you elaborate on what the Set parameters are again?

What is the Group, Node and Instance?

Also, after I installed the Zway.me software, I am having issues getting information about my nodes. Forcing an interview seems to do nothing. Did you do anything in particular to get all nodes identified correctly in the zway.me interface?

I got the zway.me softare to properly identify my devices by making sure my z-wave controller did not run in openHab. I did that by editing the Serial port to something other than what it should be, in other words, I forced it to fail.

I tried to stop the openHab service, but it seems that if you kill it, it will just respawn.

When calling the API, do you get a reply other than ‘null’? If I use the link you provided, substituting the ip and nodeid for my own installation, all I get in return is a ‘null’.

This can also be done with the openHAB API. I have created a little tutorial here:

1 Like