LogicSoft ZHC5010 Z-Wave switch not recognized in OpenHab

Hi !

Getting started with Z-wave, I have gotten my Aeon Labs Z-Stick Gen5 working with Openhab 1.8.3 / 1.9 on my Raspberry PI. So far so good.

I have purchased a few Z-Wave switch modules for Danish FUGA installations (special form factor) which looks nice and should be compatible. Although recognized in Habmin (green light) it seems that the device is not yet known by Openhab/Habmin ?

In Habmin it is listed as Node 6 "Manufacturer:564 [ID:10a,Type3]

The manual/specs for the switch can be found here: http://logichome.dk/index.php/10-support-categories/5-zhc5010-technical-information

I looked at the zwave device list on http://www.cd-jackson.com - and cannot find it there. I have the node6.xml with details - but cannot see how I can upload it to the device list.

Has anyone got this switch working with Openhab - and could you please share your items for it ?

Sign up for an account on http://www.cd-jackson.com/ and then let @chris know. He will enable your account to upload the xml and create the device.

If it’s not in the DB, no one could have got this switch working :wink:

In the DB guide, you’ll find the Information how to upload the XML. (Device database -> Device list -> Green “add” button). If you want to be able to edit the DB entries, you have to register for an account. You have to edit your device data because to have to add the configuration parameters and the association groups manually.

OK - can now access the XML-upload page at cd-jackson - but it complains that the manufacturer (564) is unknown - should be “Logic Home Control” (like in www.logicsoft.dk)…?

I’ve added the manufacturer so hopefully it will work now.

XML has been updated. What should I expect as of when it is included in the device list in OpenHab and I can start using it ?

Have you already added the association groups and configuration parameters? Finally chris has to approve the data. After the device is approved, he has to update the latest zwave-snapshot binding. That done, you have to download the newest binding with support for this device and copy it to your addons folder. If you have used the official binding until now (via apt-get), you have to delete that one so that only one binding exists in this folder.

I’ve done this with a Danfoss sensor some weeks ago. It took a couple of days overall…

Thanks for the clarification. I understood the snapshot thing - was just a bit curious about the turnaround time for the binding update. I will wait to update groups and parameters in Habmin until the binding contain the new data.

Hi Martin,
You will also need to add the configuration parameters and association groups to the database to make it configurable. These are all listed in the documentation, so it should be reasonably easy to add…

This device is a complex device.When it comes to associations, for now, I would suggest to enter the associations that are listed in the “not multi channel mode” section. It looks to me like this will make 100% directly to the multi channel, so it’s simpler to add this support as it already working in the binding. Currently the binding doesn’t support association command classes other endpoints - it’s not too hard to add this, but if it’s not needed, then I’d prefer to avoid it as it will need a database software update as well as a binding update.

The only question I have is if we use the not multi channel mode, what does the device send - in fact I have this question no matter what mode is used. We need to use multi channels no matter what in order to access all 4 buttons - this is fine as the binding supports this, but I’m wondering if the device will send multi channel encapsulated status updates or not.

The best thing to do is to try it and see - if it doesn’t work, then we might need to contact the manufacturer, or try a few things to see what the device does. The manufacturer is I guess in Europe, and they’ve written a very good manual, so I would be hopeful that they might be supportive if we have any questions - let’s see…

Let me know if you have any issues entering the data into the database.


What have I gotten myself into :scream: - but OK, I learned a lot by reading the manual and have updated everything to the best of my ability. I have left out the multi channel stuff - and also all the config for the LEDs. I will happily update with those later - but as they are not absolutely nessesary, they can wait (and my switches dont have them).

Let me know what else needs to be done by me - and I will be happy to know when the binding has been updated, so that I can start playing with my own config here…

If it’s useful and not already known, the device is also listed in pepper:


I’ve added this to tonights binding - let me know how it goes…

Hi Chris
I just replaced my zwave .jar file with the current one from Cloudbees - and even if I new get a “green light” in Habmin, it is still not really recognized and I cannot do anything with it. Also, the manufacturer and device cannot be found in the “Product Explorer”.

It looks like this in Habmin:

Is the def. missing in the build - or is it due to the manufacturer also being new in the list ?

The changelog of the binding only mentions a change for a Homeseer device. Maybe chris addition came to late or he did it unintentionally for the OH2 binding?

Edit: I just took a look. He did it for the OH2 binding. @Chris: Could you do this also for the OH1 binding?

Sorry about that - I’ll add this to OH1…

OK - thanks for the add. I can confirm that I now get the switch turning green in Habmin1 and that I can get actions out of it.

I am struggling a bit to figure out how to set up items/actions to do something different depending on which switch was pressed (there are 4 in total). With my current setting I get the same action out of all 4 buttons - although the state switches between OPEN and CLOSED on each one (i.e. button 1 switches state from OPEN to CLOSED) - the same does 2, 3 and 4 - but they do it individually.

Any suggestions for item-configurations so that I can control the action/state for each button (address each button) for this ? - if not I will try out various stuff until I get it…

The device uses multi channel encapsulation, so something like “A:B:command=SWITCH_BINARY”, where A is the node, and B is the switch number (1 to 4) should work? You can also use SWITCH_MULTILEVEL for a dimmer if you want.

I tried that - but it only reacts to the items without the multi channel encapsulation. With a items-set like this:
Contact FUGA1_1 { zwave=“7:1:command=SWITCH_BINARY” }
Contact FUGA1_2 { zwave=“7:2:command=SWITCH_BINARY” }
Contact FUGA1 { zwave=“7:command=SWITCH_BINARY” }

I only get action on the item FUGA1 - and here I get open/close on all of the buttons.

There were some config stuff in the device-database which I skipped ref. your suggestions - related to multi channel mode. Is it that which is missing ?

I am off now for a few days, but will test on when I am back. Any suggestions in the meanwhile would be appreciated…

No - this was related to associations - not to commanding. The associations are related to what happens if you change the state of the switch on the switch itself (ie so that the device sends a status update automatically) - not to changing the state of the device from openhab.

Maybe there are other config items that impact this - I didn’t look at the configuration - only the associations.

I’d need to see a debug log to see what was happening…

WIll this do ? was unsure how to attach/send the log… this is just a snippet from my current openhab-log with DEBUG-setting on Zwave…