Login to 3.4.0 SNAPSHOT looping

  • Platform information:
    • Hardware: RPI 3b
    • openHAB version: latest openHABian v1.7.4b

Hello, i’ve installed latest image of openhabian on my RPI and after the installation finished, i have been able to create the admin user and logged in.
then i’ve installed the OpenWebNet Binding, launched the scan and added all things found.
Then i had to move to 3.4.0 SNAPSHOT to test the latest versione of that binding because it’s included in the SNAPSHOT version.
After moving to SNAPSHOT from SSH with command

sudo openhabian-config

i tried to login to the webpage. it asks my credentials, but when i hit enter to login, it do a flash when i see the left menu as admin, but fastly return to login page asking again my credentials.

i’ve tried also to clean cache, reboot RPI, reset password from karaf but nothing worked.
i’ve tried to rollback to to “openhab release” version, and then i’m able again to login.

can you please tell me what i’m doing wrong?

thanks a lot!

I faced the exact same problem. Had to revert to previous milestone.

Hope someone can help us to solve this…but i think the solution is not in our hands…

Rocky Linux 8.6 system updated to openhab-3.4.0~S3128 this morning and I can no longer log in using the webUI. I’ve double checked that the password I’m using is correct. Created a new admin user and that new password also doesn’t work.

Please try this workaroud until the error is fixed: