Login to Karaf-Console returns

Platform information:
Hardware: RPI3
OS: Raspian
Java Runtime Environment: Java™ SE Runtime Environment (build 1.8.0_212-b10)
openHAB version: 2.5 Build > 1576

Trying to connect to console results in notting:
Logging in as openhab

Only error in the logfile:
[WARN ] [shd.server.session.ServerSessionImpl] - exceptionCaught(ServerSessionImpl[openhab@/127.0.0.1:41562])[state=Opened] RuntimeSshException: null

Anything to get more specific error ?

Regards

Robert

Can you provide some more details? The specific command used like:

Ssh openhab@host

Hello,

i tried:
openhab-cli console
and
ssh -p 8101 openhab@localhost
Password authentication
Password:
Connection to localhost closed by remote host.
Connection to localhost closed.

Both both results in the same:
exceptionCaught(ServerSessionImpl[openhab@/127.0.0.1:39514])[state=Opened] RuntimeSshException: null

Password is habopen that what you used?

yes, i used habopen. Could not find any log to track the Problem,
cleaned cache and temp, restarted.

Well I am out of ideas. Hopefully someone else has a few. I made the mistakes I was helping with the first time I installed

Hm so luck to get it working.

Changed Password, tried to get a log.

Nothing

I have the exact same issue since 2.5M1 and it is still broken in 2.5M3 on Debian 9.

I also use the habopen password and no luck.

Any suggestions?

same problem here with 2.5M3. Worked with 2.5M1 though …
any ideas?

Me too

2019-10-23 04:07:28.906 [INFO ] [server.session.ServerUserAuthService] - Session openhab@/127.0.0.1:54228 authenticated
2019-10-23 04:07:29.328 [WARN ] [shd.server.session.ServerSessionImpl] - exceptionCaught(ServerSessionImpl[openhab@/127.0.0.1:54228])[state=Opened] RuntimeSshException: null

openhab 2.5.0.M3 on Funtoo Linux.

Same here. Issue appeared after install of 2.5M2. 2.5M1 worked fine.

Hardware: RPI3+
OS: Raspian
Java Runtime Envrionment: Java™ SE Runtime Environment (build 1.8.0_212-b10)
Also Tried: OpenJDK Runtime Environment (Zulu8.40.0.178-CA-linux_aarch32hf) (build 1.8.0_222-b178)
openHAB version: 2.5 Milestone 2 through 4

I’d guess there’s either (bad) file permissions or (bad or incompatible) ssh options such as required ciphers in effect. That’s hard to debug unfortunately.
You could try strace -qfp <java PID> -o <outfile>, try to login, stop strace and grep for ‘ssh’ and ‘open’ in the file for hints.

You can also try the verbose option with SSH to get more insights in where the error occurs. Add -vvvv to the SSH command Lin.