Logitech Harmony Ultimate remote configuration

Hi All,
Because i tried to make some scenarios with my Z-wave network, Fibaro dimmer 2 and libcheck and couldn’t manage, i decided to buy a Logitech Harmony Ultimate remote to do this job instead of HDMI check, remote which btw its a great gadget :slight_smile:
First posting here ive checked some topics and tested already a few examples but nothing seems to work for me.
In the Logitech software i have created two activities like “Watch TV” and "Movie"
The first one it turns my TV on random cable chanels and the second one it turns my TV on / open the source / select the usb externall HDD attached to my TV.

In OH i have a scenario for lights as this one:

Dimmer Living_dim "Dimmer Living [%d %%]" {zwave="2:command=SWITCH_MULTILEVEL" }
Number Living_SC "Scena"


Switch item=Living_SC mappings=[0="Film", 1="TV", 2="Cina", 3="Noapte"] icon="television"
and Rules:
/* Scene iluminat */
rule "Activare scene iluminat"
Item Living_SC changed
switch Living_SC.state{
case 0:{
logInfo("Scenes", "Scena Film Activa")
case 1:{
logInfo("Scenes", "Scena TV Activa")
case 2:{
logInfo("Scenes", "Scena Cina Activa")
case 3:{
logInfo("Scenes", "Scena Noapte Activa")

All of the works just fine and i can only dim the light in my living room as they are configured.

I tried to follow the tutorials on wiki, makeuseof and other examples but no luck.
I use OH 1.7.1 and i found all the jar addons in the addons copy folder and copied them (all three) in the addon folder.
Than i searched in the cfg files and couldnt find the Harmony section described in all tutorials so i just added at the end of the openhab.cfg file my settings like this:

################################ Harmony #######################################
harmonyhub:username=<here is my Logitech username>
harmonnyhub:password=<here is my Logitech pass>

I dont know if this is OK or not! Shouldn’t i find this section in my openhab.cfg? in my case the Harmony section in openhab.cfg it does not exist!

Anyway i tried to add some items and some rule like this:


/* Harmony */
String HarmonyHubWatchTV "watchTV" {harmonyhub=">[Livingroom:start:WatchTV]"}


case 1:{
logInfo("Scenes", "Scena TV Activa")
The activity Watch TV on the Harmony app is with space between Watch and TV and i tried in OH with space in between and still not working:


String HarmonyHubWatchTV "watchTV" {harmonyhub=">[Livingroom:start:Watch TV]"}

sendCommand(HarmonyHubWatchTV,Watch TV)

Could anyone please point me the mistake or how to make the right configuration?

Thanks All!

HarmonyHubWatchTV is a String item so I believe you need to send it a String.

Try this:


sendCommand(HarmonyHubWatchTV,"Watch TV")

Not working. Tried to use “Watch TV” and not working :frowning:
Tell me please, do you have the Hamony section in the openhab.cfg file? I didn’t have it and I just added at the end of it and than save it.
I tried also anther item:
String Harmony_Activity “activity[%s]” {harmonyhub="*[currentActivity]"}
And the sitemap:
Switch item=Harmony_Activity mappings=[PowerOff=‘PowerOff’, WatchTV=‘TV’, FireTV=‘FireTV’]

and also it’s doing nothing…

I checked the IP address of my hub with a network scanner and I use the right one!

What else do I need to do?

Thanks All!

To be honest, if I’m trying to start a Harmony activity from a rule I use the following call:


where “PowerOff” is the name of your activity so try that format instead. I’d have thought sending the command to the item should work just as well though so I’m not sure why it isn’t.

Ok, thanks I’ll try that!

Also, looking at your config…does your file contain the chevrons?


as I think it should be:


Thanks for reply man but still not working :frowning:
I renoveze the < > from the ip, username and pass in the cfg file and modified the rule according to your suggestion and still not fireing up my tv or power off …

What else? Do you have this section “harmony” in your openhab.cfg file?

I have the addons v1.7.1, do I need a newer version?


I’m using OH2 along with the new OH2 version of the binding.

Might be worth trying the latest version of OH1 and seeing if there’s been any fixes or improvements.

Oh, this means to reinstall everything … But I’ve read some comments that says the harmony works only together with v1.7.1 addons and it’s not working with other new version like v1.8 or newer.
Anyone please!

Hi All,

In the meantime I solved my problem with my Harmony and now it’s working well.
Because I have the remote and the hub, I installed the hub in my living room and it controls my Tv. I would like to ask if may I use the remote in the bedroom to control another tv! This tv it’s not a smart one but I know I can teach the ultimate remote how to control other devices. The thing is that I don’t want to use the Harmony remote and I want to control this tv from OH. Could anyone please tell me if this can be done?
I also want to make a scene that will controll a led strip which has an IR remote.
Thanks for any advice.

and how did you solve your problem?

Dude there is a new way to make your remote work with OH! Please check this topic Harmony Binding Stopped Working in OH1
It seems that Logitech made some new software update since November last year or so and you cannot use the old binding to use your remote but the new one using the discovery name! You’ll find your answer on that topic .
Be cool.

Hey, thanks for the reply. I use OH2,b ut had the same issue.
i resolved my problem by using your rule from OH1 and adapt it.