Longest openHAB running time

Just for as an off-topic, how much was the longest time your openHAB instance ran? (without restart)

Mine is still under lots of changes so the longest is around 1 month :slight_smile:

1 Like

About 2 weeks, but also constantly changing

41 days, but as I do my backups cloning the whole ssd attached to the raspberry pi I need to shut it down for that so that was an exception.

I was on OH1. The HA server had uptime of well over 2 years before I upgraded to OH2.

1 Like

53 days with a number of changes running openHABian with OH 2.5M1 on RPi off its internal SD.
I deliberately restarted the server to change its power supply as it was constantly giving me “undervoltage” messages.

Usually uptime is less but this time maintainers are busy working on ESH reintegration (i.e. no new code to try).

Please also quickly mention the last/main reason(s) for restart and if it was deliberate or if you were forced to. Here’s some choices I could think of:
OH major upgrade or minor update, OH bugfix or new functionality in new OH version (release,milestone,snapshot?), OH not taking config change (this never should be a reason !),
memory leak, OH crash or lockup, server HW or OS crash or lockup, server major upgrade or minor update, server HW works or other.

Typically not that long. I have all my upgrades automated with Ansible and I run in Docker. Every time I run the update which is every couple of days it creates a new container. I’m too lazy and have not spent the time to make the script idempotent.

I’m running 2.5 M1.

However, the machine (virtual) it’s running on usually stays up for months at a time. I think my record was 9 months, but I don’t really track this closely. Right now I’m only at 10 days because of some cleanup I had to do from a power outage I had two weeks ago. I was on a cruise when we had a historic storm at home (they call it a bomb cyclone, 100 mph winds and over a foot of snow). The house lost power for about 6 hours, far longer than my UPS could support and I clearly had something wrong with my NUT config as my machines didn’t close down cleanly and therefore didn’t come back online cleanly.

The physical machine running ESXi I only reboot when I apply an important upgrade (or we lose power for longer than three hours) so it stays up usually for a year or so at a time.

I rebuilt all the machines (5 VMs and 3 RPis which took about an hour, Andible is awesome!) ten days ago.

1 Like

usually a week, since my automated system upgrade and reboot job runs once a week :slight_smile:

I often believe/think that my changes in the .things file, related to mqtt, aren’t taking effect, and therefore had to restart openhab.

A few months ago I invested in a ups (battery backup) for my setup. The cable modem and wifi router plugs into it as well. Since then I’ve had to stop OpenHAB once because I had left VS code, three terminals, a browser and the file viewer all open for days. The desktop of the operating system locked up but I could still see the OpenHAB log running in a terminal window which was only partially visible. OpenHAB was obviously still running and still functoning because my home automation was still working. At that point OpenHAB had been running well over 60 days

Open a Github issue when you can reproduce this behavior.