Looking for 2.5M1

Where can I get OH 2.5.0M1 for downgrade?

Ok Thanks,
but I need openhabian version

Can I just install it via openhabian2.4?

There is no such thing as openHABian 2.4, it’s 1.4.1 or 1.5.
You can use the menu to change between latest stable, latest testing (milestone) and latest snapshot releases, but you cannot select any older version. If that’s what you want you need to download the package (see @rossko57’s post) and use your package manager or see here how to install older version from the repository.


I have used the command @mstormi posted about it works like a champ! Takes a few mins, just make sure to clear your cache.

Stop openHAB, then
Sudo openHAB-cli clean-cache

Hi @Thedannymullen, I’m struggling a bit with a recent upgrade to M2-1 that has made my system not starting anymore (see Openhab not starting - Error downloading mvn:org.openhab.ui.bundles/org.openhab.ui.dashboard/2.5.0.M2).

I tried to downgrade to M1-1 and got the error message. Did you encounter the same?
(Forget the grafana package signature at the end that I think is not related…)


[19:49:18] openhabian@openHABianPi:~$ sudo apt install openhab2=2.5.0~M1-1
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages will be DOWNGRADED:
0 upgraded, 0 newly installed, 1 downgraded, 0 to remove and 0 not upgraded.
Need to get 0 B/72.4 MB of archives.
After this operation, 2,751 kB disk space will be freed.
Do you want to continue? [Y/n] y
dpkg: warning: downgrading openhab2 from 2.5.0~M2-1 to 2.5.0~M1-1
(Reading database ... 50708 files and directories currently installed.)
Preparing to unpack .../openhab2_2.5.0~M1-1_all.deb ...
Unpacking openhab2 (2.5.0~M1-1) over (2.5.0~M2-1) ...
dpkg-deb (subprocess): decompressing archive member: internal gzip read error: '<fd:4>: invalid code lengths set'
dpkg-deb: error: subprocess <decompress> returned error exit status 2
dpkg: error processing archive /var/cache/apt/archives/openhab2_2.5.0~M1-1_all.deb (--unpack):
 cannot copy extracted data for './usr/share/openhab2/runtime/system/org/apache/sshd/sshd-core/1.7.0/sshd-core-1.7.0.jar' to '/usr/share/openha
b2/runtime/system/org/apache/sshd/sshd-core/1.7.0/sshd-core-1.7.0.jar.dpkg-new': unexpected end of file or stream
Errors were encountered while processing:
Updating FireMotD available updates count ... W: GPG error: https://packages.grafana.com/oss/deb stable InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 8C8C34C524098CB6
W: The repository 'https://packages.grafana.com/oss/deb stable InRelease' is not signed.

E: Sub-process /usr/bin/dpkg returned an error code (1)

I got it once. I had to run the sudo apt update again and it fixed it.

Looks like a grafana issue actually. Missed that the first time I read your post.

You could also try, Looking for the apt announcement on here and try manually adding the key.

info here