Looking fpr a working Openhab with Raspberry, Jessie, HABmin and zWave?


I tried since 3 weeks to bring Openhab on a Raspberry P2 with Jessies and the razberry board up and running. I tried manuell, apt-get and tutorial installations. All fails by don’t recognizing the razberry board as node in HABmin. Using the razzberry SW all works fine, but flipping between this controller SW and Openhab makes for me no sense. I saw in the wiki that that there are some unsolved issues with the razberry board. Now I give up and plann I to change to a zwave usb stick installation. So my question:
Does anybody of you have a uwave/OH, HABmin/raspberry installation with a zwave stick? If yes, please provide me with the exact info about the stick and configuration you are using.
Many thk in advance


I am running a Gen5 z-stick on banana pi (running Jessie) and have no major problems. Also know of a banana pi (Jessie) + z-stick series 2 running without major problems. The mail issue with these installations seems to be poor radio range which I attribute to not enough power on the usb on the BPI (probably because they are using an SSD). I have tried both apt-get and manual installations and both work.

Hope this helps

Lots of people are using Aeon sticks on the RPi, however there are problems with the RPi (original at least) in some installations - check out the warning in the wiki about duplicate messages. I’ve not had any confirmed reports of this problem on the Pi2 though, so if you’re using the Pi2 you should be ok.

I would keep clear of the old Aeon stick and use the Gen5 which has better range and better support. The older stick had problems which I don’t think Aeon ever managed to fix :frowning:

I very much doubt that USB power will make any difference. The Z-Wave radios use very little power - even when transmitting it’s only milliwatts. You could of course always try a powered hub, but I really don’t think it will make a difference…

Hi @chris, I currently have a Fibaro wall plug and communication from the wall plug to the z-stick works much better than the other way around (lots of lost packets). I also tested the system on my iMac and range was much better. If it’s not a power issue, what could it be? I would really like to improve my range.

There are lots of things that can affect radio propagation. Antenna alignment between the two ends, noise sources (ie RF noise) close to one end that can impact the receiver. Just because it works fine one way, doesn’t mean it’s a problem with the transmitter…

As to the question of what you can do - probably nothing unfortunately :frowning: Devices in the ISM bands have to live with interference from other devices in these bands - it’s one of the conditions of the license, and they all have poor antennas. You could pull your stick apart and put a better antenna on it - that might help - or it might destroy it :smile:

If you really think it’s power, then try a powered USB hub, but as I said, these devices use milliwatts so it’s unlikely to make a difference. Of course, putting a hub in the system might help by moving the device slightly, which might be all it takes… With these systems (and I don’t limit this to Z-Wave) the quality of the link is far from an exact science…


I already get my new AEOTEC Z-Stick Gen5. I installed a brand new Raspi P2 with noobs5.0 (Jessie)
Then installed OpenHab according the wiki with apt-get.
I did the adaption for the stick and sudo /etc/init.d/openhab status shows:
pi@raspberrypi:/ $ sudo /etc/init.d/openhab status
● openhab.service - Starts and stops the openHAB Home Automation Bus
Loaded: loaded (/usr/lib/systemd/system/openhab.service; disabled)
Active: active (running) since Sa 2016-01-30 17:56:37 CET; 31min ago
Docs: http://www.openhab.org
Process: 972 ExecStartPre=/usr/share/openhab/bin/setpermissions.sh (code=exited, status=0/SUCCESS)
Main PID: 1158 (openhab.sh)
CGroup: /system.slice/openhab.service
├─1158 /bin/sh /usr/share/openhab/bin/openhab.sh -o
└─1185 /usr/bin/java -Dlogback.configurationFile=/etc/openhab/logback.xml -Dosgi.clean=true -Declipse.ignoreApp=true -Dosgi.noShutdown=true -Djetty.port=8080 -Dopenhab.con…

Jan 30 17:56:37 raspberrypi systemd[1]: Started Starts and stops the openHAB Home Automation Bus.
Jan 30 17:56:55 raspberrypi openhab.sh[1158]: 2016-01-30 17:56:55.344 [INFO ] [.o.core.internal.CoreActivator] - openHAB runtime has been started (v1.8.0).
Jan 30 17:57:01 raspberrypi openhab.sh[1158]: 2016-01-30 17:57:00.998 [INFO ] [o.o.i.s.i.DiscoveryServiceImpl] - mDNS service has been started
Jan 30 17:57:01 raspberrypi openhab.sh[1158]: 2016-01-30 17:57:01.227 [INFO ] [o.o.i.s.i.DiscoveryServiceImpl] - Service Discovery initialization completed.
Jan 30 17:57:11 raspberrypi openhab.sh[1158]: 2016-01-30 17:57:11.192 [INFO ] [penhab.io.rest.RESTApplication] - Started REST API at /rest
Jan 30 17:57:17 raspberrypi openhab.sh[1158]: 2016-01-30 17:57:17.031 [INFO ] [.o.u.w.i.servlet.WebAppServlet] - Started Classic UI at /classicui/openhab.app
Jan 30 17:57:24 raspberrypi openhab.sh[1158]: 2016-01-30 17:57:24.719 [INFO ] [.o.io.habmin.HABminApplication] - Started HABmin REST API at /services/habmin
Jan 30 17:57:30 raspberrypi openhab.sh[1158]: 2016-01-30 17:57:30.053 [INFO ] [.z.internal.ZWaveActiveBinding] - ZWave ‘updated’ with null config
Jan 30 17:57:30 raspberrypi openhab.sh[1158]: 2016-01-30 17:57:30.170 [WARN ] [i.internal.GenericItemProvider] - Attempted to register a second BindingConfigReader of type…ain active!
Jan 30 17:59:48 raspberrypi systemd[1]: Started Starts and stops the openHAB Home Automation Bus.
Hint: Some lines were ellipsized, use -l to show in full.
pi@raspberrypi:/ $
My first question:
How is the best method to start: Debian7 method (whezzy)
sudo /etc/init.d/openhab start
sudo /etc/init.d/openhab status
or Debian 8 method: (jessie)
sudo systemctl start openhab?
Doing the last one only I don’t see any zwave messages?
Then installed HABMIN manual according github:

pi@raspberrypi:/usr/share/openhab $ ls
addons bin configurations contexts etc LICENSE.TXT README.TXT server sounds webapps
pi@raspberrypi:/usr/share/openhab $ cd webapps
pi@raspberrypi:/usr/share/openhab/webapps $ ls
habmin images README static
pi@raspberrypi:/usr/share/openhab/webapps $ cd habmin
pi@raspberrypi:/usr/share/openhab/webapps/habmin $ ls
HABmin-master master.zip
pi@raspberrypi:/usr/share/openhab/webapps/habmin $

meaning creating /usr/share/openhab/webapps/hamin
sudo wget https://github.com/cdjackson/HABmin/archive/master.zip
sudo unzip master.zip
Moving org.openhab … files in addon folder
pi@raspberrypi:/usr/share/openhab/addons $ ls -l
insgesamt 3396
-rw-r–r-- 1 root root 1202164 Jan 10 22:14 org.openhab.binding.zwave-1.8.0.jar
-rw-r–r-- 1 root root 1133742 Okt 2 13:15 org.openhab.binding.zwave-1.8.0-SNAPSHOT.jar
-rw-r–r-- 1 root root 1134175 Okt 2 13:15 org.openhab.io.habmin-1.7.0-SNAPSHOT.jar
-rw-r–r-- 1 root root 126 Jan 10 22:31 README

when I try to login I get error 403 forbidden.

using (accoring guthub page, I get website not found?

Any ideas?

Many thanks in advance

I’m not sure if this is your only problem, but you have 2 copies of the zwave binding running. If this stops zwave running, then it will also stop HABmin running…


thanks I have it up and running. Habmin shows the zwave stick as node all looks fine. next problem the stick doesn’t recognize my fibaro door opener (FGK-101). I cannot insert it by doing three fast klicks on tmp button. :frowning: