Lutron Homeworks Binding Offline-Configuration_Error

I’m an ultra- super newbie, I mean incredibly new. i hope to learn more but it may take 4 lifetimes. I am envious of the knowledge level here. OK, I have 2 separate Lutron Homeworks QS systems in separate buildings. They are on the same network. The discovery works on one system and not on the other??? System-1 works great, all lights/switches are discovered and respond to commands. System-2 is discovered but shows “Offline-Configuration_Error invalid username/password” on the processor, switches and lights. They are all in the Inbox but when added they show the offline message. when I log onto the processors and review the xml file, they are different. I don’t know what they mean, cant read them other than see they are different. Its really frustrating. can anyone help? thx

Were you ever able to get this working? It sounds like your second HomeWorks processor was just set to something other than the default password. The binding doesn’t need a valid password to pull discovery information from a HomeWorks QS processor, but it does need it in order to successfully connect and come online.

I’d be interested to hear if you were able to successfully discover and configure all of your HomeWorks devices. Getting the binding to 100% coverage of HomeWorks devices is sort of an on-going project, because HomeWorks supports a LOT of devices.

Yes, I did get it working. After hours of investigating, it took a 5 sec call with a Lutron tech. Turns out that Lutron (Homeworks) changed its protocol such that all third-party integrators need their own username/password. So in my case 2 processors had old firmware so it worked fine. 2 processors had updated firmware so they did not work. All the Lutron devices were discovered fine, just couldn’t control them. I could logon to the Lutron processor directly thru the IP address and using Lutron default login (lutron/lutron or lutron/integration), but that did nothing. The Binding has to have its own un/pw. In the Lutron Homeworks Designer software, go to Tools >Configuration Integration>Telnet and setup a openhab un/pw. Then go back into the Lutron Binding and put in the un/pw – solved.

Now my problem is the openHAB status does not get updated. If I turn a light on from a standard Lutron wall pad, it does not update the status in Paper, Basic or HABpanel. My other bindings update fine, so its just Lutron?? As far as I can tell, all the functionality is there, you just get unreliable status because everything wasn’t controlled thru openHAB. So, if the light is on and HABpanel says its off, I can move the slider and the light will respond appropriately and the status matches the light.

I’m sorry I didn’t see this message earlier! I probably could have saved you some time with that.

Hmmm. That shouldn’t happen. You should consistently be getting updates to all of your items no matter what caused the state of a device to change.

First, you should check to make sure all of your Lutron things show status Online. Although you probably already did that.
Second, you should look at or tail your events.log file, and make sure you are getting messages like “FrontLampPost_LightLevel changed from 100.00 to 0.00” when you change a dimmer. If you aren’t, I would check to make sure the corresponding item is linked properly, then set logging for org.openhab.binding.lutron to DEBUG and see if you are getting messages from the processor when you change the level of a dimmer. They should look like “~OUTPUT,10,1,50” for device 10 set to a level of 50%.

It would also be good to check if you have any unsupported devices or configurations. Grep your logs for messages from discovery containing “Unrecognized device type” or “Unable to determine model”.

thx for the quick response. I checked all that you mentioned (except logs). I’ve uninstalled/reinstalled items/things to see if that made a difference, nope. This is where I get lost. i have no idea how to look at the logs. I cant even find log files. I only found 1 log file openhab-tmpfs.log?? Synology NAS/OH 2.4

Sorry, I’ve never used openHAB on Synology, so I don’t know where the logs are hidden. You can probably search the forums or ask other Synology users here. The openhab-tmpfs.log might be it on that platform. What is in it?

If you can access the openHAB console, you can at least get some log information. Look at the console commands log:display and log:tail for viewing log info, and log:get and log:set for configuring the logging level. It would be pretty difficult to try to debug anything without access to the logs! Worst case, you may want to install an openHAB instance on another platform temporarily for debugging.

This thread may give you some hints on accessing the karaf console on Synology, especially toward the end of it:

I don’t know how you guys got to where you know so much. I feel like I’m running in quicksand. Everyone talks like "oh, just do this, do that. When you are a newbie, you don’t know any of the terms so its like gibberish. i have spent so many hours just looking for config files, log files. If only there was a tech support. I could say walk thru this and I would be on my way. i cant do this anymore. thx for your help

Yeah, there is a steep learning curve. It’s best to start as simply as possible. You may be better off installing on some other platform initially, since it seems like it isn’t obvious how to manage openHAB and debug configuration problems on Synology. If you are familiar with Linux, it’s relatively easy to install openHAB on a distro like Ubuntu using the instructions on the download page. If you have a Raspberry Pi (or want to get one), it’s probably even easier to install openHABian. I also recommend reading through the docs multiple times until they start to make sense. :slight_smile:

Configuring the Lutron binding for RadioRA 2/HomeWorks QS is usually pretty straightforward if you use the the management GUI (Paper UI). A lot of people like to use config files, and there are advantages to that, but at least initially I would recommend using the management UI, and just accepting the things out of the discovery inbox. The first time you can even leave simple mode on so that your items are configured automatically, although I’d recommend turning it off later.

Normally, basic RA2/HomeWorks integration should pretty much just work at that point. If you are still having problem, you can send me the configuration XML files from your HomeWorks processors, and I can see if there are any unsupported devices in them. I’d be interested to see them anyway, because if there ARE any unsupported devices I usually like to try to add support for them to the binding. As I said before, HomeWorks supports a lot of devices and some unusual configurations.

that’s good advise. I have read thru the documentation many many times, each time it makes a little more sense but not enough. I was ready to give up last night, no, i did give up. But this morning I ordered a Raspberry. So I’m going to give it one more shot. I feel close but every binding has some little thing that’s not quite right and i get stuck trying to figure it out. The Lutron for example, all my devices seem to work but the status update. I have 96 dimmer modules with 4 circuits on each one. That’s 400 lighting circuits with at least 10 fixtures on each circuit. Habpanel has to reflect the status accurately or my wife will kill me. Russound works great but i cant figure out how to run it on in the morning. Then my next monster is modbus. i have 20 PLC’s that I need to interact with and I don’t expect that to go without issues. Maybe with the Pi, I can follow along better. thx for you offer to help, that could be a game changer. i’ll see how the Raspberry goes. thanks again

That’s a lot of lighting controls! Sounds like a cool system. I’m pretty confident that you should be able to get the Lutron binding working properly. You may be having a problem because you have multiple processors in your system, or because you have some currently unsupported devices, or because some integration IDs are not exposed (I believe it is possible to mask them in the HomeWorks programming software).

A good first troubleshooting step while you are figuring out a new openHAB installation would be to log in to each of your processors via telnet and see if you get an update message when you change the state of a connected dimmer zone. An update message should look like: ~OUTPUT,10,1,50, where the first number is the integration ID for the output, the second (1) means zone level, and the third will be the dimmer level expressed as 0-100. If you don’t see an update message, try entering the commands:


Then try it again and see if you get a response. If you are interested, the Lutron integration protocol is documented here, but it isn’t necessary to understand it in order to use the binding. I’m not actually sure if, on each processor, you will only get update messages for dimmers controlled by that processor or if you will get them for all dimmers in the system.

I don’t know much about the Russound or modbus bindings, but I’ve found that people on this forum are pretty responsive if you have specific questions.

That was interesting. The Lutron documentation was helpful, I’ve never used telnet like that before. So, yes I’m getting the proper messages back. I get the same message whether i hit the actual wall panel or the Lutron phone app or on Paper UI. The light responds properly too. I have only configured/linked 1 processor and 1 light to keep it simple. Doesn’t seem to matter which light/processor I link, the same issue persists. The openHab log does not show the wall pad or phone inputs, but it does show the Paper inputs. I don’t know how to set the Debug. no errors in the log

Which log file are you looking at? In the events.log file you will only see state changes to items. You need to look at the openhab.log file, and in order to see the messages from/to the Lutron processor, you need to enable debug or trace level messages in the log. The easiest way to do that is probably from the karaf console, using the command: log:set TRACE org.openhab.binding.lutron

You should see a lot more message being written in to the log once you set this. BTW - To change it back to the default use log:set INFO org.openhab.binding.lutron. A full description of logging is here.

Now when you change a dimmer level you should see a log message like:

2020-05-17 11:37:32.034 [DEBUG] [ron.internal.handler.IPBridgeHandler] - Received message ~OUTPUT,35,1,75.16

Those are the same integration protocol response messages you saw when using telnet to access the processor directly. But you should also see some messages about how the binding is handling the message. If there is a problem, you should see it there.

If you press a keypad button, you should see some messages like:

2020-05-17 11:37:32.238 [DEBUG] [ron.internal.handler.IPBridgeHandler] - Received message ~DEVICE,28,81,9,0
2020-05-17 11:37:32.239 [TRACE] [n.internal.handler.BaseKeypadHandler] - Handling command DEVICE [81, 9, 0] from keypad 28
2020-05-17 11:37:32.295 [DEBUG] [ron.internal.handler.IPBridgeHandler] - Received message ~DEVICE,28,88,9,1
2020-05-17 11:37:32.296 [TRACE] [n.internal.handler.BaseKeypadHandler] - Handling command DEVICE [88, 9, 1] from keypad 28

OUTPUT messages are generally from dimmers, switches, shades, etc. DEVICE messages are generally from keypads.

Update, Lutron problem solved. I set up the 3rd party un/pw- but set the user type to admin. Apparently Lutron does not like that. I changed the user type to user and now it works fine. HABpanel properly reflects the updated light status.