Lutron RadioRA 3 Compatibility

The PR with the discovery change for RA 3 has been merged. I’ve also built a new version of the binding with the changes to support LEAP button events on top of the current 3.4.0-SNAPSHOT version. That is available here:

Thanks for your work @BobA
I have nothing to contribute yet but I’m about to order some RA3 equipment. I’ll be moving into a newly build house in about a year and am looking to use RA3 (as well as hue). I have not had good luck with z-wave and seems like lutron is the way to go here. Looks like RA3 stuff is about 4 weeks out right now so it’ll still be a bit before i get a shot at trying this.

Thanks @waspie. Please let me know when you get it and are able to test it out. I’m planning to buy a RA3 processor and a couple of devices to test with, but I haven’t gotten around to it yet. I’ve been hoping the new outdoor plug would be out soon, since a couple of those would make both good test devices and useful eventual additions to my system.

I’ve found the Lutron RA2 devices to be much more reliable than z-wave devices, but they are more expensive. I also have no experience with the newer “X” devices, which use a higher frequency. But RA3 supports both the older RA2 devices and the newer “X” SUNNATA devices.

Thanks @BobA, sorry but it took a lot longer than I expected to get back here.

I now have a fresh installation of openhabian (snapshot 3.4.0 build 3149) along with your patch above. The old log entries are no longer there (the “Lutron device with unknown DEVCLASS discovered via mDNS” from before). In fact, the logs don’t show anything.

I assume this “thing” must be added manually, which brings me to my earlier question. How to get the Keystore File, etc?

Thanks!

Hi @Dogmaphobic. Sorry, somehow I missed seeing your message until now. Yes, you’ll need to manually configure the bridge device. You should see it appear in the discovery inbox, and you can accept it from there.
The binding docs for the leapbridge thing should tell you what need order to set up the keystore.
See: Lutron - Bindings | openHAB
and: Configuring LEAP Authentication | openHAB

Hey, just wanted to throw a comment in here in case others are searching for this…

I am testing this alpha2 binding on OpenHAB 3.4.1 with my Lutron Caseta Smart Bridge Pro and some Pico keypads (mostly 3BRL keypads). Uninstalled the old binding, dropped the jar from the Releases page into /usr/share/openhab/addons, and restarted openhab.

So far so good! I’ll play around with it some more, though, and provide some feedback in a week or two.
I hope to see this merged into the official binding before too long.

Looks like my 4B Pico remotes aren’t being recognized automatically with the alpha2 version.

19:35:50.503 [DEBUG] [.discovery.LeapDeviceDiscoveryService] - Discovered device: Master Bathroom Master Tub Pico type: Pico4ButtonZone id: 27
19:35:50.503 [INFO ] [.discovery.LeapDeviceDiscoveryService] - Unrecognized device type: Pico4ButtonZone
...
19:35:50.524 [DEBUG] [.discovery.LeapDeviceDiscoveryService] - Discovered device: Upstairs Bathroom Upstairs Tub Pico type: Pico4ButtonZone id: 46
19:35:50.525 [INFO ] [.discovery.LeapDeviceDiscoveryService] - Unrecognized device type: Pico4ButtonZone
...
19:35:50.542 [DEBUG] [.discovery.LeapDeviceDiscoveryService] - Discovered device: None Pico 5 type: Pico4ButtonZone id: 61
19:35:50.543 [INFO ] [.discovery.LeapDeviceDiscoveryService] - Unrecognized device type: Pico4ButtonZone

The integration IDs are there in the logs, though, so I was able to add them as Things manually, but I haven’t tested the channels on them yet (they’re set up solely to trigger events in OH, not linked in the Caseta app to any lights or anything).

Thanks @davecorder. I will add the “Pico4ButtonZone” device type to the discovery code. Which part number is the Pico it is discovering? I assume it starts with “PJ2-4B-”. I’m wondering if it recognizes other 4B variations.

@BobA thanks for the binding it’s been working very well now for quite a while on my RA2 system. I’ve finally gone ahead and purchased a couple of RA3 dimmers as it sounded the binding had the foundations of support for them.

I can confirm that discovery and connection to the RA3 repeater work. Getting a list of devices from the repeater doesn’t function like a Caseta repeater though. Request /device from RA3 returns nothing which makes the binding stop.

I have updates that work, at least for me, GitHub - peterwoj/openhab-addons: Add-ons for openHAB . I’ve also created a PR with the changes for some feedback [lutron][WIP] Update device discover for RA3 support by peterwoj · Pull Request #15445 · openhab/openhab-addons · GitHub

As I mentioned in a post long, long ago, I have a Caseta Smart Bridge Pro and things were working great with the “alpha1” release from @BobA on my OH 3.4 install, especially with regards to the Pico button events via LEAP.

A few weeks ago, I upgraded to OH 4. A while later I was doing some cleanup and removed the alpha1 jar, thinking I no longer needed it now that I was on 4.0.

Then, the other day, I finally noticed that the couple of Picos I have as standalone scene controllers no longer worked properly (they don’t get used much these days, in lieu of my Alexa integrations with OpenHAB). I did some digging tonight and wasn’t even seeing anything from the binding at the TRACE level, and eventually circled back to this thread that I had completely forgotten about. I disabled the 4.0 binding and added back the 3.4.0-alpha2 version and my Picos started working again.

I’m guessing the “LEAP Button Events” changes never got merged into the main openhab-addons code? Any idea if/when that might happen?

I ran into this same issue when updating to OH 4. I’ve been running with the “alpha2” for quite a while and it’s been flawless. Is there any plan to merge this into the main branch?

I saw that the RadioRA3 compatibility fixes got merged into the latest milestone build, so that’s nice.

I imagine someone just needs to put together a pull request for the button events changes and send it through. If @BobA doesn’t do that soon(-ish), I might try to find some spare time to do it myself…I haven’t looked at what his changes actually are, but I doubt they’re very complicated.

Hi. Sorry that I haven’t done much with this for a while. I just built a new development environment for OH4.1, and have finally re-based the LEAP button event “alpha2” test binding on the latest OH4.1 development branch and built a new “alpha3” version. I haven’t been able to test it yet, but it is the same code as before, just merged into the latest 4.1 version of the binding. I’m curious to know if it works properly with RA3 systems.

Awesome! I will probably jump on 4.1 once the stable release is out, and then I will give alpha3 a try with my Pico remotes!

Woohoo, 4.2 includes the Pico button press change in the official binding!