Main powered zwave nodes stuck at node initialising: PING


Running rpi4+aeotec stick 5 + usb hub. Openhab 3.2

Have a zwave network with 60 nodes+which is behaving strangely. When I reboot the rpi I often get USB errors (when looking at dmesg), need to pull out the Aeotec stick a couple of times and it will recognize it eventually.

After I get it online, most of the nodes are pretty much stuck at:
node initialising: PING for most of the nodes.

This also for the mains powered units.
I have tried to heal the network - no luck

I got some “controller offline” issues in the log I can see. Could it be a problem with the controller/USB connection?

Log can be found here:Zwave Log

I have also tried removing some dead nodes, but the tool wont let me remove all of them (2 left)

Please, anyone have any pointers. Its driving me crazy and the whole house isnt working = wife not happy!

Thank you!

How long have you been running the Aeotek stick on the rpi4, and how old is the stick? The older Aeotec sticks have a hardware issue that causes them to not work (or work very unreliably) on the rpi4.

Hi, been running around 1.5-2 years years now.
Must admit we had alot of trouble in the beginning with several usb hubs/ errors with the controller going offline etc.

I have a Rpi Model 3 I can try, think this will perform better?

It’s an interesting problem. You can read about it here.

In short, when plugged directly into the rpi4, the stick won’t work. But when plugged into the rpi4 through a USB hub, it works (sometimes).

I just went through it myself with an old stick and an rpi4. I tried a cheap USB 2 hub but still couldn’t get it to work. I ended up getting a new stick.

Not sure if this is your issue, but it was fresh in my mind so I thought I’d mention it.

Yeah, thanks! I have this problems often that it doesnt create the ACM0 port as well.

I’ll try a Rpi 3 first if thats better perhaps or else I need to buy a new stick.

Yeah, if ACM0 is not showing up, that’s definitely a symptom of hardware issue with the stick. Of course, it also could be a symptom of some other problem…