Manual configuration doesn't take effect

Hello all,
i’m new to OpenHAB and home automation in general. Some words to my setup so far.

Raspberry 3 with openhabian 1.4
Java Runtime Environment: openjdk 1.8.0_152
openHAB version: 2.2.0-1

I already add some rollerShutter (homematic) via the paperUI and they are shown and working so far. Now i tried to configure and add the astro binding Addon but the changes i did to /etc/openhab2 doesn’t take effect. I installed the astro binding addon with paperUI and did the following changes to /etc/openhab2 config folder …

in Items folder i added astro.items file

DateTime Sunrise_Time "Sunrise [%1$tH:%1$tM]" { channel="astro:sun:home:rise#start" }
DateTime Sunset_Time "Sunset [%1$tH:%1$tM]" { channel="astro:sun:home:set#start" }

in Things folder i added astro.things file

astro:sun:home  [ geolocation="52.5200066,13.4049540,100", interval=60 ]

and in Sitemaps folder i added astro.sitemap file

sitemap Astro label="Sonnenverlauf" {
	
	Text label="Sonne" {
		Frame {
			Default item=Sunrise_Time
			Default item=Sunset_Time
		}
	}
}

So, nothing too complicated. But in the classicUI my Sitemap is not being shown and i have no idea why. Maybe somebody can help me with that issue.
And for me it doesn’t feel correct to configure some stuff in the UI and some stuff in the configfiles manually, maybe you can tell me or give me a link where i can get some information about best practice of how to configure openHAB2.

Sorry for my ignorance.

Greetings and many thanks so far
Michel

I checked you example and it works.
Try to restart openhab.
For Sunrise and Sunset interval=86400 (once per day) is enough.
Check if PaperUI Control shows this values.

I already restarted the raspberry but this doesn’t help.

Thanks for your contribution.

do you start with

…:8080/classicui/app?sitemap=astro
try

…:8080/basicui/app
…:8080/classicui/app

also

:slight_smile: no i didn’t. And now my sitemap is being shown.
But why isn’t it shown when i open

:8080/classicui/app

here i just become my things shown i configured in the papaerui.

Thats correct. In the ClassicUI you have to enter to name off the sitemap.

In order to open your BasicUI sitemap as the default you need to set it on PaperUI. (Configuration/Services/UI/BasicUI ) Select Configure and scroll down to Default Sitemap.

Many many thanks you guys.

Maybe you have a hint about best practice whether to cnfigure items and things by paperUI or manually with the configuration files?