Manual installation of bindings in OH 2.1 not working

I did a clean installation of OH 2.1 when it came out.
After this, I can’t get manual installation of binding to work.

I download the .jar file, from the same place as everyone else, and place it in /usr/share/openhab2/addons/
I then change permission on it, so that it’s owned by the openhab user and group.

I have restarted both OH and the entire server, but nothing happens.

Did we change something in OH 2.1, or am i missing something ?


maybe the bundle did not become active due to missing dependencies
which binding are you trying to manually install?

check within the openHAB console the status:

bundle:list -s

you should have some entries in your openhab.log about this

Right now i’m trying to install the new Dropbox binding (
But I have also tried the UBNT binding, with has worked on the same server before.

In the Bundle:List -s the dropbox binding is not listed, and there is no error in the log, that i can see.

I have just tried to restart OH again, to check.

careful when you download the *.jar files from github. the link shouldn’t point to the blob entry but rather to the raw entry
open up the jar with a util to check it

thanks. i think you are right. i jus tried v 1.9.0 and it worked.

1 Like