Map in multi info widget

component: oh-map-page
  label: Localisation BMW
  tileLayerProvider: OpenStreetMap.Mapnik
    --f7-navbar-height: 0px
    --f7-navbar-font-size: 0px
    --f7-navbar-bg-color: transparent
    --f7-navbar-border-color: transparent
    --f7-navbar-link-color: transparent
    --f7-navbar-text-color: transparent
  - component: oh-map-marker
      label: position
      item: BMW420_GPSCoordinates

That’s pretty strange. What browser are you using? Are you on a Mac or iOS device?

The initialZoom property is just supposed to be a number value. 1 means zoom out to the world view and higher numbers are higher levels of zoom-in. However, on a closer inspection, it may not work in your case. It seems that the initialZoom property is only used when a map is opened that has no markers on it (not sure what the reasoning behind that decision is). I think the only way to change that would be to put in a feature request on the UI github page.

It doesn’t work on safari, but it works on firefox. The problem is solved.

Thanks for your explanation for the zoom setting. I had a good understanding of the doc, but I thought it was due to the value as I didn’t know what number to enter.
Thanks a lot for your time, explanations and kindness.


Yeah, I remember there being some issues with this on ipads and I don’t know if it was ever resolved. You could try adding

--f7-navbar-tablet-height: 0px

and see if that helps.

If I recall @Oliver2 was working on this, he might know better what the tweaks are required for ipad/safari.


Not working on ipad despite adding the last code you provided neither on safari or firefox.

Thanks a lot

Kind regards


This topic was automatically closed 41 days after the last reply. New replies are no longer allowed.