Maximum number of DatagramSockets reached

Any idea how to sort this out? Using Ubuntu 16.04, just added a load of Yeelights. The first one worked, but none of the others do… I do have about 150 ‘things’ so is it related to that?

Ummm… so to summarise… you dont know the answer, in which case, move on. Don’t need your input, you aren’t someone in the ‘helpful community’ that I was trying to get a response from :slight_smile:

I don’t know the answer because I have no information about your set-up apart that you are running Ubuntu 16.04
You haven’t posted any config, items, or logs
How do expect any help if you can’t provide the info required?

As every issues is different, different information will be required… I cannot post everything, and your recommendations in the link you provided and useful, for some cases.

The Title I gave the post states the error, hence it is the title. I gave the operating system in the description. I gave the binding in the description also. If someone wants to help, or genuinely has an interest in helping then I would post whatever they needed, what is not helpful, and much less informative then my original post, is posting your own article on what you think should be how it’s done. I already did my research and no one seemed to have a similar issue hence the post. If you can’t help, why reply?

Fine, good luck…

1 Like

@swieprecht Hm. You should know that @vzorglub is one of the most helpful guys around here, if you stick to some simple rules mentioned in the linked post. That is your OH version, binding version and so on.

To give you the answer you desire, but I suggest everyone to leave this thread alone from there on:

No. It’s not.


Okay… so what did he tell me that was helpful? He posted a link to his post? He didn’t even say next time maybe include…

Thanks for ‘suggesting’ that everyone leave this thread alone… I guess that is why most reviews suggest the HA community is a lot more friendly, because some members throw their weight around.

Fortunately I have had the huge pleasure in also being able to speak to some really friendly and support members on here, who whilst may not agree that I ‘called out’ someone for being unhelpful, did give me pointers and support.

I absolutely think you should take your own advice then and '‘leave the thread alone’ although thank you for confirming it isnt to do with thing amounts.


True that it’s his own post but that’s not the point why Vincent posted it. The post in that link is widely reviewed and accepted as a guideline on how to ask for help. So could you help us to help you and provide more info about your system? Rlated things, items, configs, oh version, java version, logs,…

Actually, I retract that. I will say that I apologise if you or anyone has taken me pointing out I didnt find the reply helpful offensively, but I do stand by my original point, that if I had missed information, which given the issue I dont think I did, as I dont think it is version specific, then telling me that rather than posting a link wasnt helpful.

I can but I genuinely didnt realise that information, given the issue, was going to be needed. If I had read the post, I also still genuinlely don’t know I would have included that as it seems quite specific. I did as much research as I could online but I found nothing of use other than it MAY be to do with UDP ports.

It’s OH 2.4 (stable) and I an running with OpenJava.
It’s the Yeelight devices, but on the MI IO binding that all show that error (although having rebooted the error went).
Is did run an ss -s command as someone suggested, and that has said there are 76 INET open, but I dont know that helps - I run a really big network of devices.

The only other thing that may be of use if that I recently went from a Pi to a Hyper V installation (as Pi was struggling to cope RAM wise). I therefore now have to use a USB to IP to pass my RFXCOM and ZWAVE through to Hyper-V.

No idea if that makes a difference, but if its connection related I guess it might?

Have you tried turning it off and on again? just kidding :smile:

The datagramsocket is related to connecting to the lights I guess. If it exceeded it’s likely or you have to much devices or somehow datagramsocket were not correctly freed and still occupy a slot. In that case it might be a bug or something else maybe in the system. In which case restarting might actually fix the problem. However it is good to see if it keeps happing and disable some bindings in a ordered way to trace which binding gives the problem or what other program use network resources.

Sorry I can’t help you with your question but now we see that you have done lots of research. Why didn’t you tell us this in the first place? It would’ve gotten all us to the same line. Thanks.

Haha… it did clear the issue… I guess my main reason for posting was to see if it was common. I know the MI IO Binding is Markplace so in Beta so it may be a bug with it, although it hasnt come up in any of the searches.
Didn’t know if maybe this USB to IP thing was making a mess of my connections… to be honest, I love these YeeLight things so I have 20 of them, plus about 8 Gateways, and then another load of WiFi devices, so I dont know if the 38 TCP connections is about right given all that.
Guess I’ll see if it repeats and maybe send it straight to the binding developer :slight_smile:
Thank you

Thank you for trying… I’m hoping it won’t repeat. I’ll keep an eye on the UDP and TCP numbers too in case.
S :slight_smile:


I’ve run into the same issue on OH 2.4 with Yeelight devices as well. When you say you restarted, do you mean OpenHab or just the lights?

Regarding details, I have 5 Yeelights and about 10 Switches/Sensors connected to 1 gateway. They’re connected via MiHome because that was the only way to retrieve the tokens. When I run a network scan they pop up in doubles. I have Mi IO and Mi Home bindings installed.

Any advice on how to fix this would be greatly appreciated

I gave up trying to run them with MI IO in the end and went back to the YeeLight binding which whilst didnt give me as much control, didnt have the issues, and also the lights started randomly turning on with Mi IO and this stopped that.