Maximum zigbee nodes with the ember coordinator

I am using the ember zigbee coordinator with the [Nortek Security & Control HUSBZB-1 witch has been working very well. I have added Philips HUE motion detectors, Aqara temperature and humidity sensors, and Aqara motion detectors (for the last one I had to update to 2.5 milestone 5 before i started working).

But now I have run into this problem that I can not add new Aqara motion detector. OpenHAB has been able to detect detector, and the discovery process completes, all expected channels appears, but non of them works. If I look at the event log, I don’t get any events on this detector either. If I remove the detector and try to add it again, it will actually appear in my inbox before I even touch the reset button on the detector.

Then I found this commit by cdjackson, It seems to add an option to configure the network size. And inside this patch I found the define called EZSP_CONFIG_ADDRESS_TABLE_SIZE. Which when I google for it it seems to have the value 8.

My current node count in my zigbee network is 8, so may this be the cause for why I can not add more nodes? So I will have to wait for this option to become available in openhab? It seems a bit strange that I can discover and add the detector to my network, but it doesn’t send any events?

It’s unlikely this will cause any issue, or help. The number of nodes in a ZigBee network is not dictated by one device - nodes can join via any router (ie any mains powered device). Most mains powered devices will handle 8 to 16 devices. If you have no mains powered devices, then this will limit the number of nodes you can have - I’m not sure how many that is off the top of my head, but it’s not related to the PR that you have referenced.

Ok, yes, all my devices are battery operated except the coordinator. So I will need to buy some smart plugs or something like that to be able to increase the size of the network?

How many devices do you have? I think that I have the NCP configured to allow 16 devices to connect to it.

In my network I have currently 8 working battery operated devices + the coordinator. I have only tried to connect the Aqara after I reached that number. Maybe I should try with an Philips HUE devices which seems to be much better supported (or maybe behaves more according to spec.)

The binding is configured to allow 16 child devices (ie battery devices) to connect directly to it, so this shouldn’t be an issue. The HUSBZB is an older device - maybe it has other limitations (although I don’t really think that’s the case)

What version of the binding are you using? (sorry I just re-read the above and see it’s 2.5).

I remember now that I have a 9th device, I have a Philips HUE bulb that I was planning to use with the motion detector. So I can have more than 8 devices. So now I am wondering why I was able to connect one Aqara motion detector, but not the next one.

I have a NRF52 Zigbee sniffer, and have been trying to capture some logs with Wireshark. When I try to attach the motion detector to the network I can see this Beacon messages with Extended PAN ID. So it seems that something happens when I try to attach.

Here is the trace file if you want to have a look:

EPID is found as package 169 and 219, OpenHAB was in discovery mode.

I will also need to know your network key.

14 c6 a2 c7 fb e0 c3 19 8e 7c 36 30 dc ad a5 96

Unfortunately that doesn’t seem to work. All I can really see is that the beacons (which are not encrypted) show that joining is enabled.

Ok, that is the network key I have set in my thing configuration file.

Essentially a copy&paster of this extended sample here:

Is there any other way to obtain the network key?

It can be sniffed when a device joins the network (assuming it’s using the standard link key used for joining, otherwise that is also encrypted, but most devices still do this). However as there are no devices joining, this isn’t in the log you provided at least.

If I remember correctly, the TI dongle doesn’t allow the host to read back the key, but I’ll double check this as I might be wrong (Ember does, Telegesis doesn’t…).

Sorry, I am kind of a newbee, but by “joins the network”, you mean a new device that the network does not know from before? I tried to make a trace when I turned the Philips HUE bulb on, but I can not see any trace of a network key there.

I uploaded the capture if you want to have a look:

The bulb is source 0x7791, and you see it communicating at package 74 and 75

As I have not yet made any automation for this bulb yet, I though I could try to remove it from the network and try to make a trace when I rejoin it to the network to see if we can get the network key from that.

Btw, I can see that my network is using a different EPID than what I have defined in the things file too. So maybe those parameters doesn’t apply?

Yes, exactly. It must be a new node.

If it was not joining the network, then it won’t exchange keys.

They should have, but maybe the network was initialised some other way such that these values are no longer correct. I need to check if it’s possible to read them.

I am starting to wonder if there is something wrong with my OpenHAB installation. I was trying to add a new Aqara Temperature sensor today which has worked multiple times before. This time it didn’t, but in the trace I can see the same EPID beacon messages as with the motion sensor.

Seems like I may need to reinstall my OpenHAB installation. The only problem I have is that it is already controlling lights around my house so need to find a suitable time to do this. Any way I will come back with the result and if I was able to add the Aqara motion sensor with the new install.

I have reinstalled OpenHAB, so now I can add Aqara devices that I have not try to network before (straight out of the box). But the once I had in the network before I did the reinstall, I can not attach to my new network. It works fine with the Philips HUE devices, but not with the Aqara devices.

So I ended up ordering a CC2531 USB stick. Seems like it gives me a few more options.

To reinstall a device that has been removed from the network, or if a new network is created, you will need to reset the device. On the Aqara devices, if I remember correctly, you need to hold the button down for some time until the LED flashes.

Once a device has been reset, then you will be able to add it into a new network.

Yes, I do, I hold it for about 3 seconds until the led flashes.

Just a small update,

I finally got the Aqara motion sensors that I had paired before working with my new Zigbee network. After some googleing I figured out that it’s not enough just resetting the Aqara sensors when you want to pair it with a new network. You must keep them alive for some time by pushing (not holding for 3s) the button regularly (intervals of 2-3 sec) to make sure the discovery process finishes. I did this on my Amber coordinator as I have not go my CC2531 dongle yet, and it worked with one sensor so I hope it will work with the rest.