mDNS when running behind nginx

Tags: #<Tag:0x00007f617e3eff80> #<Tag:0x00007f617e3efa80> #<Tag:0x00007f617e3ef828>

Hi,

I’ve set up my OH2 behind an nginx reverse proxy - mainly for HTTP authentication. The setup is working fine, I’ve just one problem: OH keeps announcing the internal port via mDNS. This port is not reachable to the outside (binding to localhost), and I’d love to get rid of the announcement.

Is there any configuration option to disable mDNS announcements?

cheers
Bernhard

PS: Sending the proper announcement for the “official” TCP port was easy - I just definied a static service in the avahi config of the machine.

Updating my question with my own findings:

According to this source code file there seems to be an “enabled” property to disable mdns announcements. Unfortunately, I couldn’t figure out yet how to set it (which exact property name in which file) so that it is actually switched off.