Miele Cloud Binding not found


recently I bought a Miele washer and would like to integrate it in Openhab (version 3.4.2). As far as I understand that binding doesn’t have to be installed but should be running out of the box, calling /mielecloud. When I do so the output is: “Sorry - Requested content not found”.
I upgraded the system (Opanhabian on a Raspberry Pi) as well as openhab itself via openhabian-config. Can anyone give me a hint on how to resolve this.

Thanks in advance and best regards.


You will have to install a binding for this.
http(s)://openhab:port/settings/addons/binding-mielecloud, then follow the readme: Miele Cloud - Bindings | openHAB

Good luck!

Thanks for the fast reply. The result is and empty white page with just a “back” link in the top left corner of the page. Not even an error massage is shown.

That was supposed to read your openhab instance and then straight on to the addons settings page.
You do have access to the settings page? The addons ‘store’ should allow you to install the linked binding.
Once you have installed the binding you can go to your openhab instance on the path /mielecloud and link your account.

The binding Miele Cloud is not available for installation. There is only a binding Miele@home available for installation but that is a different addon.

Can you paste output of what version for openhab is stated here:
http://openhabip:8080/about ?

It seems you’re on an older version (<3.1?). The mielecloud binding has appeared in version 3.1: Miele Cloud - Bindings | openHAB

openHAB 3.4.2

Release Build

  • Konfigurationsverzeichnis


  • Verzeichnis für Anwenderdaten


  • Verzeichnis für Protokolldateien


  • Betriebssystem

Linux/5.10.103-v7+ (arm)

  • Java Laufzeit

Azul Systems, Inc.

11.0.9 (Zulu11.43+88-CA)

Allright, so it seems you have the correct version, but I’ve been dense.
Might it be that you haven’t enabled remote addons yet?

This is the first setting I set when installing, but it’s been some time ago that I last did that.

Yes, looks pretty much the same as your screen capture.

But you get a blank screen on /settings/addons ?
I’ve setup a new host using docker and after initial login I get under /settings/addons the option for both miele plugins.
To be honest I think there’s something up(rather down) in the cache of your openhab instance, but not knowledgeable enough to say for sure. If it’s a cache issue I’m not sure how to clear that properly(if package based openhab-cli has an option, if openhabian I’m sure it’s in the menu). Other than time, it seems not destructive as an action to perform.

I did

openhab-cli clean-cache

but unfortunately the Miele Cloud binding doesn’t work anyway. I guess I will have to set up a new openhab system to resolve this issue.
Thank you so much for your time and support.