Migrate openhab from Rpi 4 to Rpi 3+b

Hello there,

I would like to migrate my Openhab Setup from my Rpi 4 to my Rpi 3+b because the Rpi 4 should serve another purpose from now on and my Openhabian is not as ressource hungry as initially thougt. Nvertheless my setup includes some handcrafted rules and settings I would be happy not having to set them up again manually.

My prequesites are as follows:

  • Migration intended from Rpi 4 to Rpi 3+b
  • My Openhabian is upgraded to 3.01
  • Razberry2 Module in use via zwave.me and zwave binding
  • Congbee2 controller in use with Phoscon drivers and hue binding

A first attempt to migrate everything with the backup & restore functionality provided by openhabian (openhabian-config) failed. Although bringing back my rules, things and items, the bridges where not functioning at all and I noticed razberry and congbee drivers where not there (could have anticipated that, I know). So I decided to “roll-back” with the help of the cloned SD card image I carefully made before starting the migration. Now I am back in my old environment and ready for your tips, what else needs to be backed up, restored or re-installed in order to make the migration successful.

In openhabian-config backup RPi4 and save file somewhere
Install fresh openhabian on RP3
Copy backup file to RPi3
Restore backup using Openhabian-conifg on RPi3

Best way of doing it

Hello @Adrian_Hills,

thank you for your quick reply. But as you may have read, I tried this already and it did not work. Unfortunately it seems Zwave and Zigbee Hardware and the according Drivers, bridges is not backed up and restored that way.

Did you try to just boot from the old SD card ?

Drivers will be there they just might have changed their device name so you need to adapt that in your config.


thanks for that hint. I just tried to boot the Rpi 3+b with the old SD card image, but it seems openhab is not running correctly: I can not reach it from the local network under http://openhab:8080 nor with the IP and the port. Also not after systemctl start openhab But surprisingly the Phoscon App seems to be running and reachable via the network.

You mentioned

changed device name


adapt that in your config

Is it possible that this has to do with the not (correct) starting of openhab?

Unlikely but possible if you run an old installation. But if OH does not run that’s an OH issue so you have to go debug that.

Ok thanks for your answer. What would be the next step to start debugging that?

Enable debugging in Karaf console and analyze the logs to see where it is failing.

Ok thank you. It seems after a reboot that openhab is somehow running. I can use most of my things any many rules work, eventhough not all. But unfortunately the Web-Frontend is not reachable.

Can you help me find the relevant info with debugging to get the Frontend running again?

No time sorry. And beyond scope of this thread.

Indeed. Thanks.