Migrated to OH3 - Rules Page won't load

Tags: #<Tag:0x00007fc8f62b6a30> #<Tag:0x00007fc8f62b6968> #<Tag:0x00007fc8f62b6878>

I’ve migrated to the OH3 release today…

a couple of niggles - but the biggest one is when I go to the rules page - it just doesn’t load - sits there animating - but no rules…

I’ve tried deleting the rules json files and the old .rules files - but that page still won’t load.

Any ideas?

On the upgrade - it told me the latest version of java (which openhabian-config was installing) was unsupported - and the openhabian tool doesn’t seem to acknowledge that the upgrade is complete - as its still offering me the upgrade…

OH3 requires Java 11, preferably Zulu Java. The latest Java 15 is not supported. Java 11 is the latest long term support version.

1 Like

I kind of get that (java versioning is not something I really understand) - it was 11 it was trying to install…there’s an option in openhabian config to install zulu 11 and even when you do that it says its not been tested…

Hi,

Did you find any solution for this? I’m experiencing the same issue (I’m using Zulu 11 - tried also other JAVA 11 versions but no luck so far).
Any hints from Community?

I can confirm same problem here after migration from 2.5 to 3.0. Rules page just “loading…” and showing animation.

Previously had some experimental rules enabled on OH 2.5. Interesting that rules itself are working correctly after migration to OH3 but I can’t access them and/or modify.

openhab@openHABianDevice:~$ java -version
openjdk version “11.0.9.1” 2020-11-04 LTS
OpenJDK Runtime Environment Zulu11.43+55-CA (build 11.0.9.1+1-LTS)
OpenJDK Server VM Zulu11.43+55-CA (build 11.0.9.1+1-LTS, mixed mode)

I managed to get back working Rules page.

  1. Cleared the content (not deleted file itself) of /var/lib/openhab/jsondb/automation_rules.json
  2. Stopped OpenHab
  3. Cleared cache openhab-cli clean-cache (or Clear the Cache - Setup, Configuration and Use / Runtime - openHAB Community)
  4. Started OpenHab

And Rules page is loading correctly (sure, without any of rules, but as I had just only two, it’s not problem for me).