Migrating from Linux to Windows

I’ve tried to migrate my OH3 from Ubuntu to Windows. Backup/Restore doesn’t (complains about a missing Persistence folder but the folder is there). Copying the userdata and conf folders doesn’t work - I added the missing services items.

This is the error message

Launching the openHAB runtime...
Error occurred shutting down framework: java.lang.NumberFormatException: null
java.lang.NumberFormatException: null
        at java.base/java.lang.Integer.parseInt(Integer.java:614)
        at java.base/java.lang.Integer.parseInt(Integer.java:770)
        at org.apache.karaf.main.ConfigProperties.<init>(ConfigProperties.java:251)
        at org.apache.karaf.main.Main.updateInstancePidAfterShutdown(Main.java:232)
        at org.apache.karaf.main.Main.main(Main.java:197)

Does anyone have any idea what I need to change?

Migrate back to Ubuntu :smiley:
No seriously, using windows for openHAB is a terrible idea. With the mandatory updates and all…

Are the two versions of OH exactly the same version? You can migrate by copying the userdata and conf folders (though you should probably exclude the tmp and cache folders under userdata) but only if the OH versions match.

That error looks like you are attempting to copy the configs from an older OH to a newer OH where there was some changes made to some of the config files. The upgrade process would normally handle fixing that but by just copying the files you are bypassing the upgrade process.

Both version 3.3

I’m having issues with Ubuntu constantly swapping USB ports on reboots - despite symlinks. I ran OH2 on Windows for 4 years just updating on a monthly basis

Just a shot in the dark here but did you manually copy the java .jar file for your java client back to the addons directory? I found when I updated to openhabian buster and restored from a backup that the one file I had to handle manually was the java client .jar file for my mariadb client/persistence setup.


Don’t seem to have any .jar files in addons - just the .kar file

As the backup should be a zip archive, please open the archive and try to move (ok, copy) them to the appropriate folder manually.

That’s what I did after the Restore failed.

There might be some configuration within the files, that uses an absolute path

I’m having issues with Ubuntu constantly swapping USB ports on reboots - despite symlinks.

To me this sounds like throwing the baby out with the bath water. You are in all likelihood (assuming you are at least relatively comfortable with linux) going to have a far smoother experience running it on Linux than on Windows.

Why don’t we instead try to see how we can fix your issue?


Just my 2 cents here but I seem to recall seeing that message before on windows install when my java environment variables were bonked up.
I assume you have done a nice clean virgin install already and tested that it came up and played nice?
And then only after you did the restore it all went to see the devil?

I have been running OH without any hardware or Linux issues with Ubuntu for years.
I have a Zigbee/Zwave combo USB dongle.
My Linux “server” is a NUC sized hockey puck from ASUS. It is connected to a KVM via USB.
I have never had a “port switch”.
I have a windows server I use for storage. I have been unable to convert it to a Linux ZFS storage server because I used Windows storages spaces and the “windoze resilient file system”. It always gives me headaches.
I would NEVER use windows as a critical server.

1 Like

Esp as sounds like needs just permanant mount options being added to fstab file
Alt for that would be GUI tool to make the chnages permanent

Swapping USB Ports is managed by udev rules better than fstab. There is more usb hardware than a storage system.

1 Like

It is but this is about drives

No the issue was with serial ports. I have resolved it by re-creating the Things and cutting and pasting the code

I was using OH from version 1.X in Windows 10 without any issue in a miniPC, running in same machine with Grafana, Influx, Zigbee2MQTT, Weather-Display and some other custom software. So is valid to run it, no more (or less) problems that other platforms.