Migration from 4.0.3 to 4.1.2 - after restoring backup, Bindings seem broken

Hi there!

I tried upgrading my 4.0.3 installation on a RPi3 to 4.1.2 via openhabian-config. That didn’t work out (UI wouldn’t work, sudo service openhab status gave the following error: java.lang.illegalstateexception: resource has no uri).
So I installed a fresh 4.1.2 OpenHABian from scratch and restored my 4.0.3 backup on it.
Restoring seemed to work, but the bindings and other Apache karaf features seem to be broken.
The bindings and persistence services that I had installed on the old system all look like they are installed (the add-ons page lists them with a “remove” button in red), but when I click on that, I’m asked to “install” them. If I do, there’s a loading circle that won’t finish.
What’s more, every add-on is listed twice (no matter whether I installed them or not).

It looks like restoring the backup from 4.0.3 broke the add-ons, but how can I repair that? I could start again with a fresh install, but not restoring the backup is not an option, really.

Thanks for every hint!

Do you have anything in your /addons folder?

Please try

  • sudo openhab-cli reset-ownership
  • sudo openhab-cli clean-cache
  • sudo systemctl restart openhab.service

Yes, that worked. In the meantime, I found this thread:

…which described basically the same problem, although the thread wasn’t that easy to find.
Cleaning the cache and rebooting (twice, in my case) worked. I can’t remember whether I ran reset-ownership (not by openhab-cli, but by openhabian-config), but I think I did that, too.
After it all worked out, the duplicate addon entries were gone, all “normal” addons showed as installed, and the only marketplace addon I had installed (WizLighting) was gone, but reinstalled without problems.

Thank you all!

1 Like