Migration from OH2.5 to OH3

Hi all,

I have just upgraded from OH2.5 (running on RPi3 - openhabian) to OH3. Upgrade seemed to have run fine. (I’ve created my admin account during initial setup)

However, a few things:

  • This warning is displayed when logging into putty:

sed: can’t read /var/lib/openhab2/etc/version.properties: No such file or directory

  • openhabian version seems to still be: openHAB 2.5.11-1 ()? (this doesn’t seem right, was expecting 3?)

The above seems pretty alarming? Or am I just being overly cautious?

All my .things .items and .rules seem to have migrated over as expected. Although, I know that there is a new semantic model for OH3. I’ve previously setup groups using the historical .items files, my question is; is there anyway of migrating those as well as my sitemap using config files or is it only UI based now?

In addition to the above, I’ve found frontail very useful and this no longer seems to work…is this supported in OH3?

Apologies for all the questions and please feel free to correct me if my understanding is incorrect :slight_smile:

Many thanks in advanced

1 Like

How did you install and how did you upgrade.

oenHAB 3 moved everything to just openHAB .folders. No more openhab2.

When you log in, something is looking for the current version of OH in the wrong place.

It’s not actually new. But in OH 2 it was only used if you also used HABot.

There is no rule that says all your items and Groups need to be a part of the model. You don’t even need to create a model. But if you do, it’s unlikely that your existing Groups would go into the model.

So yes, you can keep using your existing Groups.

FronTail is looking for the logs in the weekend place. I think you need to change the. service file to look for the right log file in the right place (again, no more 2).

1 Like

Thanks for the response @rlkoshak!

I upgraded using the openHABian configuration tool using the following command:

sudo openhabian-config

I did not know this - thanks for the heads up!

Yes, understood - been doing a bit more playing around and understanding the new structure is bit a more challenging (I’m sure I will get there)

Could you please provide a bit more clarity around this? What is the name of the .service file? I cannot see anything related to FronTail in my ‘services’ folder, can only see addons.cfg and so forth (unless I’m looking in the wrong place. Also - can this be accessed from the MainUI?

Many thanks as always!

I don’t use Frontail so I can’t help much. I know systemd names the files the same as the service name. So it’s probably names frontail.service.

Frontail is not part of openHAB. It’s a completely different project and service that really has nothing to do with openHAB. openHABian installs it and configures it to read openHAB’s logs but that’s it. So you need to look in the operating system’s files.

I don’t think so.

Guessing you just use the log files themselves?

With regards to the warning on load of terminal - any ideas what could be causing this? (mentioned in my first post)?

I’m using OH 3 so I use the event stream in the developer sidebar and when I need to I use multitail to follow openhab.log.

The login shell is looking for the the current version of openHAB in the wrong place. I don’t use openHABian so I don’t know what shell it uses. Assuming bash it’s probably in the .profile or .bashrc file.

I can access the event stream in the developer sidebar. However, I’m going to ask an absolute noob question, but what is the command for multitail to follow?

Thanks as always!

Hi ,

have someone a tipp to restore my habpanel.config from 2.5 Version ?
After Upgrade to 3.0 the complete habpanel Settings Widgets are gone :frowning:

1 Like

Just open the log files with multitail.
You do not need a parameter like -f (which you need for tail).

2 Likes

If you want to remove the warning on load of terminal and get the proper version of installed openhab you have to manually edit the .bash_profile file which is located for openhabian user in /home/openhabian folder.
For the correct version you need to the change the line which begins with OHVERSION and for the right build you need to change the line which begins with OHBUILD.

Change these 2 lines like this:

OHVERSION=$(dpkg-query --showformat='${Version}' --show openhab)
OHBUILD=$(sed -n 's/build-no\s*: //p' /var/lib/openhab/etc/version.properties)

and you’ll get rid of the warning and the wrong version number

6 Likes

Thanks, had the same problem but that fixed it! :slight_smile:

Also on login I see the following message:

Wi-Fi is currently blocked by rfkill.
Use raspi-config to set the country before use.

This is confusing because raspi-config is not available on openhabian:

This helped me eliminate the warning and the incorrect OpenHAB version when launching OpenHABian.

For the benefit of anyone, like me, who only has a limited knowledge of Linux, you won’t see the .bash_profile file with a simple ls command. You need ls -a to see the hidden files (such as those beginning with “.”). You will need some type of editor. I used vim.

Thanks for sharing the solution.