Milight Binding ok but lamp doesn't switch


(hhaensel) #1

Hi,
I am completely new to openHAB and I am experiencing my first difficulties!

I installed the latest version on an old synology NAS 215j :slight_smile:
I setup the milight binding and found the IBox2 and many things such as milight:rgbwwLed:09558c4b:1:ledbrightness. I think I linked the channel correctly to a dimmer and switch item, so that the dimmer goes to 0 in a HAB Panel, when I switch off the lamp.
BUT: the lamp (a dual white LED) doesn’t switch.

Maybe, I have an old version of the white LED? (It is sold via Brilliant)

With the latest Milight 3.0 App I can control the lamp via smartphone, so in principle the connection works. But in the list of devices no “whiteLed” is offered.

I hope one of the experts can help me!

Thanks in advance,
hhaensel


(Vincent Regaud) #2

Could you post a screen shot of the channels offered by the thing?
And also add a little info about your system

See:How to ask a good question
Items: 4, 9 and 11


(hhaensel) #3

Thank you for involving yourself and sorry for my delayed answer (family, kids, …)
I am using openHAB 2.3.0.005 on a Synology DS215j with DSM 6.2
IBox2 is successfully recognised via Milight-Binding.
The table of things is that is being offered upon searching Milight is

All rgbw color - RGBW Led
Color (iBox) - IBox integrated Led
Rgbw Color (Zone 1) - RGBW Led
Rgbw Color (Zone 2) - RGBW Led
Rgbw Color (Zone 3) - RGBW Led
Rgbw Color (Zone 4) - RGBW Led
Rgbww Color (Zone 2) - RGBWW/White Led
Rgbww Color (Zone 3) - RGBWW/White Led
Rgbww Color (Zone 4) - RGBWW/White Led

The thing Rgbww Color (Zone 1) - RGBWW/White Led is not offered, as I have used that one for my testing.

Meanwhile I have played around a bit with the Milight 3.0 App. In this app there is a selection of remote controls and only with one I get my LED panel working: remote2, I cannot bind my lamp to any RGBWW-Remote control …

Thanks for any comments in advance,
hhaensel


(David Graeff) #4

Have you checked rgbw as well as rgbww and is the zone definitely correct? Try the “all” thing as well if in doubt.

The oh 2.3 milight V6 support is working but has a leak that will sooner or later flood your logs and consume all available thread resources. Upgrade to oh 2.4 as soon as it’s out.

Cheers David


(hhaensel) #5

Hi David,
sorry for my late reply. It took a while for me to test, as I waited for the new synology package to come out. Now I have upgraded to OH 2.4 but the status has not changed :frowning:
Zone is definitively correct and I tried all possible lamp types.
I now tried to switch the lamps with a python script ( Milight-Wifi-Bridge-3.0-Python-Library), but also there no reaction, although the command is accepted. (Wrong address or port lead to an error message). I run out of ideas. :frowning:
Thanks for your help anyhow.
HH


(David Graeff) #6

Milight V6 is unfortunately not documented anywhere so all community projects are doing guesswork only. But it’s strange that it doesn’t work for you. For me it does at least most of the time.


(Skinah) #7

If the problem stems from using a V6 bridge, why not change to the opensource bridge? It is working very well and have not had any issues running this on any version of Openhab.


(hhaensel) #8

Thank you for all your comments. I also found the EspMilightHub project and got the hardware running :slight_smile:
Unfortunately, I can’t get the OH settings right. If I send {“state”:“ON”} to the topic milight/commands/0x89EA/cct/1 by an external program (MQTTBox), the lamp switches. However, if I configure a Generic MQTT Thing and set the command topic of the Switch channel to “milight/commands/0x89EA/cct/1” no response of the broker is received. The broker is online.


(Skinah) #9

Did you visit the link in my last post? that link is to a binding that does the hard work for you. Setting up Generic MQTT Thing sounds like you are manually trying to use the mqtt binding the hard way.


(hhaensel) #10

Stupid me! Will try tonight!


(hhaensel) #11

Tried and worked right away :slight_smile:
Both projects “Milight Hub” and “EspMilightHub Binding” are really awesome. (By the way, I could run the v2 binary file on my v3 ESP8266 without problems and it was recognised by Windows 10 right away without driver download!)
Why would one want an IBox :wink: (Mine (Home-Wize) did receive commands from Shanghai to allow for switching away from home - without asking…)
Thanks to all who helped so quickly :+1:

P.S.: My cct led bulb does switch very slowly between different levels of brightness or temperature. Can that be changed somehow? It might be an intrinsic property of the lamp, though.


(Skinah) #12

I totally agree, the opensource hub works perfectly and is very actively worked on with new features all the time.

See the readme file at the github project for optimising the speed and reducing delays between bulb changes. The thread also has some info.

The older cct globes can not go directly to X brightness and instead need to turn off and then send multiple increase brightness commands to reach the target brightness. Those globes are very cheap to buy but do not work as well as the RGB_CCT versions which are a newer better protocol. Instead of only needing to broadcast a single command, the cct globes may need 6 commands to be broadcasted so it is more critical to optimised the settings.


(hhaensel) #13

Got it :bulb:
I will play a bit.
Thx a lot!