Milight binding session timeout

 [WARN ] [nal.protocol.MilightV6SessionManager] - Session timeout!
 [INFO ] [nal.protocol.MilightV6SessionManager] - Confirmation received for unsend command. Sequence number: 311

This is being spammed in my log every ~10 seconds. Anyone know what the issue is? The binding is working as expected otherwise.

I don’t know this binding but I would guess there is some sort of unexpected delay in messages passing back and forth to whatever the binding is communicating with or the network is disconnecting.

From the OH machine see if you can ping this device (assuming it’s on your network) or some other device/computer on your network. Are you getting a fairly consistent time? Is the time pretty large?

On your OH server, are you running out of memory or CPU?

If you restart OH do those log statements go away for awhile?

These are generic trouble shooting steps. If they don’t help I won’t be of any further help. But I’ve tagged this with milight so hopefully it is more likely to get the attention of the right users.

1 Like

Here is the ping test for the bridge.
The CPU and memory is good.
The logs start showing it almost instantly post initialization.

Thanks for the assistance in debugging this.

The times for the ping look good. But you want to continue running the ping so that you get some pings around the same time that you get the timeout log. On Windows use ping <address> -t and it will continue to ping <address> until you hit <crtl>-c instead of only running 20 times or so.

How much memory is the openHAB process specifically using?

I’m afraid to say that this is looking like something we will need a binding maintainer to look at to move forward. You machine looks powerful and the network appears solid (pending the rerun of the ping test).

Yes that message is expected on OH2.4 and hidden on OH2.5M1 and better.

I am running 2.5M1.

That’s a mystery then. I’m pretty sure that I have hidden the connection lost messages if they happen in a shorter period then 1 minute.

Need to lookup the code at some point.


Hi, I have the same issue and run OH 2.5.10! Did you find a solution?

I fixed it by lowering the Keep Alive Interval to 2000 on the Bridge Things properties.

I still see this problem in Openhab 3.2. As I setup all my things with files, because I have a better control of the things and items, I would like to now if I can set the keepAliveInterval by using a parameter, too?

Bridge milight:bridgeV6:F0FE6B4B064E “Milight Bridge” @ “Bath Room” [ host=“”, bridgeid=“F0FE6Bxxxxx”, passwordByte1=0, passwordByte2=0, repeat=1, delayTime=100, keepAlive=2000 ] {

I tried keepAlive and keepAliveInterval with no visible change.

What is the correct parameter-name?


i found it myself by looking into the jar-file. The parameter-name is refreshTime

And I can confirm, that the warning dissapears after setting it to 2000 :slight_smile: