Missing addons

New to OpenHAB having migrated from a very outdated VeraLite. I’ve obtained OpenHABian and wrote the image to an SD, let it go through the setup and all appears well. I’ve picked the 2.4 stable channel and when I go to addons > bindings in Paper UI there are a whole bunch of bindings available for 2.4 as expected. What is unexpected though are the two addons I was trying to install (That both have a 2.4 in the addons list on the website) are missing (Logitech Squeezebox and Daikin). Am I doing something wrong? Have I missed something?

Edit: I am able to install other required bindings successfully, just not the two listed.

Do you have legacy bindings enabled? It’s found on PaperUI > Configuration > System > Addon Management. Remember to click save after turning on.

If that doesn’t help then you can install by using the jar file.

Daikin jar file
https://openhab.jfrog.io/openhab/libs-pullrequest-local/org/openhab/binding/org.openhab.binding.daikin/1.14.0-SNAPSHOT/

Squeezebox multiple to pick from jars
https://openhab.jfrog.io/openhab/libs-pullrequest-local/org/openhab/binding/org.openhab.binding.squeezebox/

Will need to do some searching for Logitech or is that part of squeezebox? To add the jar files above place then in usr/share/openhab2/addons then restart OH.

I tried enabling legacy bindings just in case (But the addons page states they have a 2.4 version?) but it still did not list them. Logitech Squeezebox is Squeezebox.
Am I correct in understanding that the versions listed up the top right mean there are packages available for it in 2.2, 2.3 and 2.4?

Yes, that list allows you to select the appropriate documentation for the version your using.

I have no answer for why some bindings are not listed in PaperUI. If you want the binding, as mentioned above, place the jar file in usr/share/openhab2/addons and restart OH. If for some reason the binding doesn’t work or you decide you no longer want it then simply remove the jar.

I’ll try that and see if it works. Does that mean I will need to manually update the binding every time there is an update or once it’s enabled will it automatically check for updates?

For an update I’m not sure if bindings in usr/share/openhab2/addons get updated automatically or not. If not just remove the old jar file and replace it with the new. Notice on the squeezebox link there are several versions to pick from so updating would be removing 2.4 and adding 2.5. Personally, once I have a binding setup and working I don’t worry about updating unless there’s a new function that I want added.

That’s usually my preference too but when Squeezebox Server gets updated then it may need a new binding to accommodate the changes. It’s not the end of the world if I have to manually copy a couple of files but it would be nice to know why they aren’t appearing.

Who knows.:smile: I’m just glad we have the flexibility to manually add bindings.:+1:

If you have problems after adding the jar files you might want to use sudo openhabian-config tool and select Apply Improvements > Fix permissions. Others have needed to do this on their system when adding a new jar. Let us know how it works out for you.

I’m not getting the binding appearing at all. Installed bindings doesn’t show it and adding new ones doesn’t list it to enable.

[03:41:50] openhabian@openHABianPi:~$ sudo openhabian-config
2019-02-23_03:41:51_AEDT [openHABian] Checking for root privileges… OK
2019-02-23_03:41:51_AEDT [openHABian] Loading configuration file ‘/etc/openhabian.conf’… OK
2019-02-23_03:41:51_AEDT [openHABian] openHABian configuration tool version: [master]v1.4.1-453(1380125)
2019-02-23_03:41:51_AEDT [openHABian] Checking for changes in origin… OK
2019-02-23_03:42:01_AEDT [openHABian] Applying file permissions recommendations…
$ adduser openhab audio
The user openhab' is already a member ofaudio’.

$ adduser openhabian audio
The user openhabian' is already a member ofaudio’.

$ adduser openhab bluetooth
The user openhab' is already a member ofbluetooth’.

$ adduser openhabian bluetooth
The user openhabian' is already a member ofbluetooth’.

$ adduser openhab dialout
The user openhab' is already a member ofdialout’.

$ adduser openhabian dialout
The user openhabian' is already a member ofdialout’.

$ adduser openhab gpio
The user openhab' is already a member ofgpio’.

$ adduser openhabian gpio
The user openhabian' is already a member ofgpio’.

$ adduser openhab tty
The user openhab' is already a member oftty’.

$ adduser openhabian tty
The user openhabian' is already a member oftty’.

$ adduser openhabian openhab
The user openhabian' is already a member ofopenhab’.

$ chown openhab:openhabian /srv /srv/README.txt

$ chmod ugo+w /srv /srv/README.txt

$ chown -R openhab:openhab /usr/share/openhab2

$ chown -R openhab:openhabian /opt /etc/openhab2 /var/lib/openhab2 /var/log/openhab2 /usr/share/openhab2/addons

$ chmod -R ug+wX /opt /etc/openhab2 /var/lib/openhab2 /var/log/openhab2 /usr/share/openhab2/addons

$ chown -R openhabian:openhabian /home/openhabian

$ setfacl -R --remove-all /etc/openhab2 /var/lib/openhab2 /var/log/openhab2 /usr/share/openhab2/addons

$ setfacl -R -m g::rwX /etc/openhab2 /var/lib/openhab2 /var/log/openhab2 /usr/share/openhab2/addons

$ setfacl -R -m d:g::rwX /etc/openhab2 /var/lib/openhab2 /var/log/openhab2 /usr/share/openhab2/addons
OK
2019-02-23_03:42:13_AEDT [openHABian] Checking for default openHABian username:password combination… FAILED
2019-02-23_03:42:14_AEDT [openHABian] We hope you got what you came for! See you again soon :wink:
[03:42:14] openhabian@openHABianPi:~$ cd /usr/share/openhab2/addons
[03:43:19] openhabian@openHABianPi:/usr/share/openhab2/addons$ ls
openhab-addons-2.4.0.kar org.openhab.binding.daikin-1.14.0-SNAPSHOT.jar README
[03:43:21] openhabian@openHABianPi:/usr/share/openhab2/addons$ sudo reboot

Check with the Karaf console and see if it’s listed and active. For the console use sudo openhab-cli console at the prompt type bundle:list to see everything or use grep to narrow down the search bundle:list -s | grep daikin

Also use ls -al /usr/share/openhab2/addons to see the user and permissions.

You have two users showing, normally openhab is the only one.:hushed:

They do not.

Are you sure the Squeeze box binding (note there is no "Logitec in the name) does not appear? There is a 2.x version of it so it should show up even is “Show legacy 1.x bindings” is turned off.

The Daikin binding is apparently one of those that is not used by many users. Perhaps it was never confirmed to work with OH 2. I don’t have it showing up in my PaperUI either, though there appears to be an OpenDaikin binding on the IoT Marketplace. The Daikin add-on appears to need to be installed via the jar file H102 linked to.

It’s also possible that there is a problem happening right now that is not showing all the 1.x bindings that it should. This is the second thread I’ve run into where a binding I thought should show up in PaperUI is not.

You can try to file an issue in the openhab1-addons repo for Daikon.

With an openHABian install, the user login account is named openhabian. The software runs as openhab.

So I can install the Squeezebox binding now from the addon menu (no idea why I couldn’t before) but the Daikin binding is incompatible with my system as the Australian version uses a different command set than overseas. I ran Wireshark while the Daikin app was running and everything is via GETs so for the time being I will use the HTTP binding to control the unit