Missing command class SWITCH_BINARY for Qubino Thermostat (ZMNHLA2)


I’m trying to implement a Qubino Thermostat device (Flush PWM thermostat ZMNHLA2) with openHAB 1.8.1. I’ve got 15+ devices working with zwave including some Qubino devices. The devices is included ok, the node is appearing in Habmin and the temperature can be read from the device {zwave="23:command=sensor_multilevel,sensor_type=1"}. I’m trying to control the Output (Q) with a Switch item like this: { zwave="23:1:command=switch_binary" }. But this doesn’t work. I get the following error message in the log:
17:25:28 WARN o.o.b.z.i.c.ZWaveConverterHandler[:300]- No command class found for item = swHeatPumpZolderPMW, command class name = switch_binary, using 0 refresh interval
The SWITCH_BINARY doesn’t appear in the startup log either (With these messages: NODE 23: No item bound for event, endpoint = 0, command class = METER, value = 0.4, ignoring.)

The manual states that the SWITCH_BINARY class should exist. I also see it in the Product database. I noticed this remark in the Device List:
Note: This device has incomplete data. If you have this device, and have an openHAB node XML file, please consider uploading it.

I added my node.xml for this device (node23.xml).

node23.xml (15.6 KB)

Looking at the XML, SWITCH_BINARY doesn’t exist for this device. I expect you need to use THERMOSTAT_MODE or THERMOSTAT_SETPOINT (but I don’t know the device, so I’m not 100% sure).

I’ve uploaded your device to the database (thanks :slightly_smiling:).

Thanks Chris, for your quick response.
The documentation lists COMMAND_CLASS_SWITCH_BINARY as a supported Command Class, but it is obviously not returned in the list.
I’m trying to control the Output (Q) with THERMOSTAT_MODE and THERMOSTAT_SETPOINT but no success yet. I’m able to set THERMOSTAT_SETPOINT, but I’m not sure what I should set for THERMOSTAT_MODE. It can be either AUTO or OFF. Can I pass a string, or is it mapped to a number (0 or 1)?
There is also a parameter called Thermostat Mode (Parameter 59), is that the same as the class?


It looks like you should be able to set the mode to either 0 or 3 - 0 being off, and 3 being auto.

I’ve not found the doc, but it does look like parameter 59 might do the same thing as the command class, but that’s based simply on the name in the database, so I could be very wrong… If you know where the PDF is online, can you post the link?

Sure, this is the device: http://qubino.com/products/flush-pwm-thermostat/
You need to register to download the pdf’s. But the pdf can also be found here: http://www.vesternet.com/downloads/dl/file/id/1138/product/1470/z_wave_qubino_flush_pwm_thermostat_user_manual_v1_0.pdf

I will try with value 3 for the mode.


Thanks - the manual doesn’t shed a lot of light on parameter 59 :unamused:. Let me know how you get on with the mode…

Totally agree about the manual.
Unfortunately setting the THERMOSTAT_MODE to 3 didn’t do the trick. The temperature is 20,7 degrees. I set the setpoint to 26 degrees. I would expect the [Output] is switched on then, but it isn’t.
I submitted a request for support with Qubino. Let’s see if that sheds some light on the configuration.


Did you happen to get this working? I have the on/off thermostat, but seems to have very similar situation as what you describe: “Not switching on”

Replying to myself… Found out that Thermostat mode had only two options 0 & 3 (Off & Heat/Cool).
Once I did force the thermostat mode channel to 1 (By changing the channel type to allow this) the thermostat started to work ok.
This on (ZMNHID)