Missing Tailscale Connection

OH3 on RPi4:

I just did a fresh install and uncommented the preauthkey line in the openhabian.conf file and added my key. When I login to the Tailscale console though, I see their default connection and the computer I’m on, but not the openHAB instance. Is there something else I need to do in OH to make Tailscale appear in my console?

Did you uncomment preauthkey before you installed unattended ?
You can try to install tailscale again using the menu.

Yes I modified the config file before installing. So by your answer I guess it’s supposed to just show up in my console? I wasn’t supposed to uncomment the line above the preauthkey line right?

yes, no

as I said use the menu with your key. If the key is valid it should work.
(if you used a one-time key that might explain it, try a permanent one if so)

The key is listed as reusable, expiring in June. I went to the configuration tool and installed again. Teh key was already populated (I deleted & pasted again). Still not showing. I AM supposed to include the tskey - part of teh key right? Thanks for your help, this is the outupt I got when I installed it again:

2021-03-12_19:53:21_CET [openHABian] Installing tailscale VPN...
2021-03-12_19:53:21_CET [openHABian] Adding required keys to apt... OK
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100   100  100   100    0     0    280      0 --:--:-- --:--:-- --:--:--   280
# Tailscale packages for raspbian buster
deb https://pkgs.tailscale.com/stable/raspbian buster main

try tailscale up --authkey tskey-...... on the command line, that’s what openHABian does.
tailscale status will show you right that. If it does not work you will have to look for an answer yourself.
(just an idea, do you block anything outgoing ?)

That worked, so it’s just not being intialized. Looking at the debug section of the guide I see that the preauthkey is in teh openhabian.conf file at boot/ (not just now but it’s been there all along) but it’s not in the openhabian.conf file located at rootfs/etc. I DO see the path I put to the backup directory in both files so it’s a mystery why some info transferred over and some didn’t.

I very recently fixed a bug with parsing. Could you try another flash install just to check if it works this time ?

1.6.3b? That’s the one I flashed.

I was going to start other threads for this but I’ll mention it here in case they’re related: I have been working on various install-related items and focusing on this issue and the auto-backup, with the additional small issue of not being able to find the OH instance on the network via the hostname.

So this last flash I did I purposely only changed the preauthkey and the backupdrive location to /dev/sdb. Otherwise I left everything in the config file alone. The backups also aren’t working (nothing in /storage).

And as mentioned above, when I create a new install I have to go find the ip on my router because openhabian:8080 doesn’t load. I also tried ping openhabian with no success. This seems strange since it clear has openhabian as the hostname in the config file.

yes latest. Just check if it now carries your settings from (/boot/)openhabian.conf over to /etc/openhabian.conf.

The settings carried over but I still had to install it via the config tool.

So any idea why unattended setup is not working? All I’m doing is uncommenting the Tailscale key line, adding my key, and uncommenting the backup storage path line and entering my path and then saving the file and plugging it in to set itself up. It doesn’t install Tailscal or the Amanda Backup stuff. I’m not missing a step am I?

That’s two totally unrelated things and noone can know unless you provide at least a debug log.

Will do, thanks for your help.