Modbus TCP on OH3 and owen plc110

Hi all!
Can you help me for adding my OWEN PLC110-60 to OH3 based on RPi3?
on my PLC i have slave1 on port 503 with 3 dword VAR

i added modbus tcp slave
host 192.168.144.8
port 503
id 1
next add poll
start 0 len 6 type holding
but this poll not work:

Error with read: org.openhab.core.io.transport.modbus.exception.ModbusConnectionException: Error connecting to endpoint ModbusTCPSlaveEndpoint@38a6454d[address=192.168.144.8,port=503]

i installed another programs to test modbus connection,
on my Rpi3 modpoll working perfectly, and collect all data from plc
and on pc modbus scanner give all data from plc slave

but not work on OH3

So, what settings did you use there?

Hi
on req

./modpoll -t4:int -c 3 -p 503 192.168.144.8

resp

Protocol configuration: MODBUS/TCP, FC3
Slave configuration…: address = 1, start reference = 1, count = 3
Communication…: 192.168.144.8, port 503, t/o 1.00 s, poll rate 1000 ms
Data type…: 32-bit integer, output (holding) register table

– Polling slave… (Ctrl-C to stop)
[1]: 0
[3]: 4194304
[5]: 0

i change second dword for test

i have 2 tcp port in slave1
502 for owen cloud
503 for OH
both work on modpoll

As much as we can see of them, these settings would look reasonable.

How did you make the settings, are you using the UI?

Would you use API explorer to show us your three Things in detail?

[
  {
    "statusInfo": {
      "status": "UNINITIALIZED",
      "statusDetail": "DISABLED"
    },
    "editable": true,
    "label": "Regular Poll",
    "bridgeUID": "modbus:tcp:248588f27e",
    "configuration": {
      "length": 6,
      "start": 0,
      "refresh": 500,
      "maxTries": 3,
      "cacheMillis": 50,
      "type": "holding"
    },
    "properties": {},
    "UID": "modbus:poller:248588f27e:07eec9a8cf",
    "thingTypeUID": "modbus:poller",
    "channels": []
  },
  {
    "statusInfo": {
      "status": "ONLINE",
      "statusDetail": "NONE"
    },
    "editable": true,
    "label": "Modbus TCP Slave",
    "configuration": {
      "timeBetweenTransactionsMillis": 60,
      "connectMaxTries": 1,
      "reconnectAfterMillis": 0,
      "port": 502,
      "timeBetweenReconnectMillis": 0,
      "host": "192.168.144.8",
      "connectTimeoutMillis": 10000,
      "id": 1,
      "enableDiscovery": false
    },
    "properties": {},
    "UID": "modbus:tcp:248588f27e",
    "thingTypeUID": "modbus:tcp",
    "channels": []
  }
]

Okay, no Data Thing but that won’t stop it polling.

Please show all modbus binding messaging.

Is this a cross-domain issue, what is the host IP address?

Bear in mind some slaves only talk to one master at a time, make sure all your test programs are stopped.