Model not showing locations

  • Platform information:
    • Hardware: Raspberry Pi 4 Model B Rev 1.1
    • OS: Raspbian GNU/Linux 10 (buster)
    • openHAB version:3.2.0-SNAPSHOT - Build #2583

Having my OH2 installation disk fail I have started from scratch with OH3 - and had managed to get the vast majority of my Things /Items / etc recreated and linked to a previous HabPanel configuration; I have recreated some of my ‘most useful’ automation riles and all was going very well.

However today I was working in the Model and was editing some items, and changing the Parent groups of others and now the Model does not display all my locations and i have no idea how to get the model to display correctly.

The locations all appear to be ‘in openhab’ as I can find them if I go to change a parent group, and they are also displaying when I go to the Pages configuration:

And also on the ‘Locations’ page:

But do not display when I view the Model

Looking at the openhab log viewer I can see all my items changing state, etc, but do not see any error messages.

Unfortunately it is sods law as these were the last few changes I was going to make before creating a ‘stable’ version backup of my configurations so cannot revert back to prior to the changes. Any help in working out what I need to do to ‘fix’ the model and see the locations / equipment / items again would be greatly received.

The model display often breaks down silently if there is some error in any one piece of the model definition. Unfortunately it is very difficult to determine where that error might be unless you have precise knowledge of the changes made right before the issue occurred.

The first thing to try is to look into the userdata/jsondb folder in your OH configuration folder. This is where all the information about OH pieces that you have configured through the UI are stored. Fortunately there is, in that folder, a backup folder which stores older versions of the json files from before each recent change. To restore one of these files just stop OH and copy the backup back into the main jsondb folder and restart OH.

You are probably looking to restore the items file.

Thanks.

Tried copying some of the backup files and still no success.
In the end as desperation I went to where the location should be on the Model and went to create a new location called it the same thing and it was displayed in red stating ‘already exists’ but saved it anyway and then it appeared on the Model and all sub locations that were there before also re-appeared.

1 Like