Modify a zwave binding jar to add/change a zwave device while waiting for a build

I’ve absolutely no idea what this file is - it’s not what the binding wants anyway. It looks like it’s got a load of github formatting included as well as the database file. You should download it from the database website to be sure.

1 Like

According to the first non-blank line, it is some sort of HTML file.

When downloading from GH, make sure to select the raw file or you will end up downloading the html…

1 Like

I suspect it was downloaded with all the github page formatting included.

1 Like

Yes! Thanks, I got now the right one and it WORKS!!!
Thank you all

1 Like

It would have been easier to just download the latest zwave snapshot, though :sunglasses:

The database edits are already merged.

1 Like

yes, but also chris mentioned that the zwave-binding 2.5 snapshot might not run on OH 2.4.
This is why I finally decided to add the new xml file to the zwave-binding-2.4.jar.

But anyway, it works and I learned a lot :slight_smile:

I have seen many people here running it successfully using @5iver’s script or manually installing.

1 Like

I’m on OH 2.4 with this version of the zWave binding w/o any issues. It’s 9 months old though.

openhab> list -s |grep zwave
209 │ Active   │  80 │     │ org.openhab.binding.zwave

Best, Jay

1 Like

Thank you very much for posting this tutorial.

Another noob issue I ran into. I am running Debian 9 Stretch and using openjdk-8-jre-headless (amd64) for Openhab. I know Zulu is recommended but I already had this installed and in use for a couple of other services running on this server.

When I try to issue

jar -uf org.openhab.binding.zwave-2.4.0-SNAPSHOT.jar ./ESH-INF/thing/[vendor]/[XML file name].xml

I get the error

-bash: jar: command not found

solved by installing openjdk-8-jdk-headless. Probably common knowledge for a lot of folks here but it took me a while to figure out! Hope it helps someone

Why do that when there is a new, up-to-date stable version being released tomorrow?
Did you also add the entry to the zwave database for others?

Oh, I didn’t realize that was happening tomorrow. Usually I just wait for the repo to update and then poke around on here to find the changes.

I also wanted to learn how to do this anyway. Up until now I have been editing the database, then submitting it for approval, then waiting for Chris to compile the binding, then waiting for a new snapshot. Sometimes this can take several days. Today I saw the binding was updated, so I updated openhab from S1774 to S1776, but my changes didn’t seem to be in there. I eventually realized the snapshot was created some hours before the binding was compiled, so the new binding wasn’t in S1776.

Yes, I started off using the database before I found this post. I don’t know why or how someone would do this without updating the database anyway, 5iver’s instructions utilize the database (steps 4 and 5). I guess if they never clicked the “submit for review” button, it would never make it into the binding. Not sure why someone would do this, though, you would have to manually edit your own binding every time you upgraded openhab. I can’t speak for everyone but I’m way too lazy to do that! :sweat_smile:

I think Chris kicked off a manual build of that binding so somebody could see if their issue was resolved. Like you said, since it was after the snapshot you got an older one.

I usually just update the database and wait for the next export. Chris usually exports once a week or so.

@5iver please update to

1 Like

Does this also work for openhab 3?

Likely but there should be a snapshot binding later today with the latest database export from 2.5. The PR was merged late yesterday and Poland on testing this evening with a manually installed binding.

It is always recommended to update the database.

I added a new ring zwave device and just being impatient lol. It seems to have worked, but all the values for the sensor come up as null…

The database is usually exported at least once a week The OH3 one was several weeks out of data but is up to date as of a couple of days ago.

Your change just got exported to IH2 and the permanent process fix for OH3 will need to wait because of other real-life priorities, unfortunately.