Monoprice RGBW Dimmer Not in Database?

Hi, I tried installing the Monoprice RGBW LED dimmer module (, but the Zwave binding indicates that the device may not be in the database. I tried to see what I could find in the database, here (, but I kept getting 504 timeouts. I’m not sure how to add it to the database, or even check if it’s in the database. Can anyone help me out?


So, you installed it on OpenHAB. I assume you know what node it is on your zwave network.
I just looked in the database and we do not appear to have that device.
The manual online looks pretty useful. We need a copy of the xml file for that node that was generated in your /var/lib/openhab2/zwave folder. The filename should END with the node number.
That file, along with the information in the manual should help us enter it in the database.

1 Like

Thanks, yes it joined my network as node 17.
I’ve attached the xml file that was created by the binding. Is there anything else I need to provide?
network_c3f37c26__node_17.xml (9.6 KB)

Thanks, again!

1 Like

I am having issues importing that xml file but I have asked for assistance. They are probably asleep right now though.

EDIT: I suspect a new command class may need to be added to the binding first.

1 Like

I don’t see any command classes missing, but the XML file is invalid…

It looks likely that it’s been edited and it doesn’t include the <node> tag at the beginning, or the </node> tag at the end of the file so the database importer will not be able to read it.

I just tried to upload it and it seems @sihui did the same 13 seconds before me :slight_smile:

1 Like



Thanks guys! I will try it out this evening.

Edit: BTW, unless I made a copy and paste error, I didn’t edit the file manually, although I did change a couple parameters through paperui.

I saw this in the xml COMMAND_CLASS_SWITCH_COLOR and did not see it in the list here.

Is there anything special I need to do in order to get the updates from the database? I’ve tried healing the device, re-initializing it, and removing it and re-adding it to the network.

Patience padawan :smiley:

What version of OH are you running? That may affect how we tell you to manually update the binding.

The device was added 17 hours ago. According to this link

The actual binding was updated 4 days ago. After that has been updated check here for the jar file.
The last build of the jar was 1 day 19 hours ago.

1 Like

Sorry, I didn’t realize it would require a binding update. I’m using the openhab 2.4.0 Docker image.

That’s OK I am still learning a lot too, especially assisting with cleaning up the zwave database. I had to go through these steps before 2.5M2 to get my devices supported.

After the jar file has been updated, the best way to update the binding is to use this script.