Monoprice Z-Wave Plus On/Off Switch (36737) linking as "Unknown Device"

Tags: #<Tag:0x00007f43480cd900> #<Tag:0x00007f43480cd838>

Raspberry Pi 4
openHab2 - Downloaded and installed last week.

I am pretty new to this. I have successfully install a couple GE switches and a few other devices. However some Monoprice Z-Wave Plus On/Off in Wall Switches (36737) are linking as “Unknown Device”. They came up with the name “Z-Wave Node 011 (011A:0101:0101:5.11)” which I understand means they are not in the database. What is the process for doing for getting them in the database, or getting them working some other way? Any help would be appreciated. I tried searching for about an hour, but was not finding anything with clear steps to take.


Thanks for the reply. However that link gives a 404. Attempts to search for that name all bring me to 404s or to the Plesk hosing site.

The site is down for maintenance at the moment. Hopefully it will be back up later tonight.

1 Like

Hi Chris,
Thanks for taking the time to tell me this. I see it is back up. I have created an account and logged on, but I am not seeing the “Create Device button in the top right of the page”. Is this just the site not being quite ready, or am I missing something?

From the link I posted earlier:

To use the database you must first register on the site, then email, or open a ticket to have your access updated to allow you to edit the information.

First I want to apologize. I have since found everything I’ve asked in the documentation. So thanks for your patience so far.
Unfortunately, I am probably going to do it again. I have created a new device in the DB and submitted it for review. How will I know that it is complete and ready for me to download? My current understanding is that once Chris has updated the binding, I will need to uninstall the current Zwave binding, download a new JAR file, drop it in the addons directory, and restart OH2. Is this correct? Where will I find the JAR file? The links I found in other posts are dead.

Yes, all of your points.

It moves from time to time …

1 Like

There are links in the manual install steps documented in the readme for…

The Bintray link is much more consistent than the one to CI.



Thanks to all your help, I now have these Monoprice switches working. As a summary of the steps I should have taken…

  1. Tried to connect my device. The “thing” came up as an “Unknown Device”. The thing listed the Z-Wave node. Take a note of this node number.

  2. Confirmed that the device type was not already listed in the Z-Wave database at

  3. Using the link at the top of that page go to and create an account.

  4. Log on, click on my name in the upper right corner and select “My Tickets”. From there click the “Create Ticket” button. Fill out the ticket politely asking to be given permission to create new devices. I also briefly described the device and attached the XML for the device (see #6).

  5. Wait for a reply saying your account can now edit devices. This took a day.

  6. You will now need to collect three things. First, a PDF version of the owners manual for the device. Second, at least one digital image of the device. Third, the XML for the device the Z-Wave binding created when you connected it. In Openhabian, I found this in in /var/lib/openhab2/zwave. The correct file ended with the ZWave node number noted in step 1. I also cheated a bit at this point and found a very similar device that had already been defined in the database. This information help a lot in the next step.

  7. Go back the the device database, and log in. I now found a button that said “Create Device”. I clicked this, filled out the name and title, and then cut and pasted the XML from the last step into the XML box.

  8. I was now able to edit the five tabs worth of data. I copied much of it from the similar device I found in the database, but all of it could have been copied from the owners manual as well. On the “resources” tab, you will need to upload the PDF of the manual and at least one digital image. When you have it all ready, click the “submit for review” button on the lower right of the page. In my case this returned a generic error message with no reason given. Turns out the record was created and could be found by going to the database list. If I hovered over the new device listing, it showed “under review” on the lower section of the right side pane in the “first approval” field.

  9. Now patiently wait for your device to be reviewed. During this period the ticket was closed, but the device had not been reviewed. It took about 3 days for the device to be reviewed. Considering this process appears to require a recompile of the binding, that is pretty impressive. The first sign that it was ready is the “first approval” field now had a date and the badge “OH-SNAPSHOT”. My understanding it this badge means it is compiled into the “Snapshot” version of the binding, but not production yet.

  10. Going to I found the most recent Snapshot JAR file for the binding. The “Recent Changes” link on that page showed the latest update was for a database update.

  11. The installed Z-Wave binding had to be uninstalled, and this latest Snapshot JAR needed to be put in the /usr/share/openhab2/addons directory and the system restarted. There is a script at Zigbee and Z-Wave manual install script that does these steps. I downloaded this zip file and put the .SH file in /usr/share/openhab2/addons (using SAMBA). I then SSHed into the machine and issued the following commands

    cd /usr/share/openhab2/addons
    chmod u+x
    sudo -E -u openhab bash

  12. I tried using the options to install the new binding, but it came back with the error “It has taken more than two minutes to uninstall the Z-Wave binding, so exiting !!!”. I manually uninstalled the binding and ran the script again. That worked.

  13. OpenHab became unresponsive at that point, so I rebooted.

  14. I deleted the things I had created earlier, and reconnected them. The first time they came up with the correct new device type name, but they still said “Unknown Device”. Deleting them and adding them again fixed that.

  15. They then worked!

I am going to mark this as the accepted answer, because it lists all of the things I learned from the several responses I got. All of them contributed to me getting this resolved. Thank you all!

1 Like