Mosquitto error and SONOFF tasmota lazy response

Hi all,

Sorry if I’m using “beginner” expressions.

I have terrible communication stability with my Sonoff/Tuya flashed switches. the response time varies from 1 to 30 seconds. the same with the manuale touch response time.

Background:
using openhabian on RBP 3b+, mosquitto broker 1.4.10
Flashed the following modules: PSF-B85/B01 (sonoff based on ESP8285), TYWE3S (TUYA based on ESP8266)- all with similar symptoms.
used TASMOTA 6.5.0 rev with 2.3.0 and 2.4.2 cores - all with similar symptoms.

Sonoff T1 1CH Module

Sonoff

Program Version 6.5.0(release-sonoff)
Build Date & Time 2019-03-19T12:24:10
Core/SDK Version 2_3_0/1.5.3(aec24ac9)
Uptime 0T00:01:04
Flash write Count 215 at 0xF5000
Boot Count 15
Restart Reason Software/System restart
Friendly Name 1 Sonoff
AP1 SSId (RSSI) mood24 (100%)
Hostname sonoff-1162
IP Address 192.168.0.176
Gateway 192.168.0.1
Subnet Mask 255.255.255.0
DNS Server 192.168.0.1
MAC Address 60:03:94:15:64:8A
MQTT Host
MQTT Port 1883
MQTT User DVES_USER
MQTT Client DVES_85648A
MQTT Topic sonoff
MQTT Group Topic sonoffs
MQTT Full Topic cmnd/sonoff/
MQTT Fallback Topic cmnd/DVES_85648A_fb/
Emulation None
mDNS Discovery Disabled
ESP Chip Id 8742026
Flash Chip Id 0x144051
Flash Size 1024kB
Program Flash Size 1024kB
Program Size 507kB
Free Program Space 496kB
Free Memory 14kB

I did noticed if the MQTT server address is removed from the tasmota configuration, than the switches are responding immediately using the web control or manual touch switch.
which make me think that it’s maybe a mosquitto broker issue in my raspberry pi server.

[08:11:19] openhabian@openHABianPi:~$ [08:11:13] openhabian@openHABianPi:~$ mosquitto
1562217079: Using default config.
1562217079: Opening ipv4 listen socket on port 1883.
1562217079: Error: Address already in use
[08:11:19] openhabian@openHABianPi:~$

i don’t know if its the problem but i got this address is already in use error.

killed the mosquitto process till i have no error message, but as soon as i configured back the MQTT address in tasmota - the lazy response appears and the error also in my openhabian.
also, if killing the process and clearing the error, regardless the tasmota, after rebooting the error appears again.

Any idea how to fix this address is already in use error, which hopefully will fix also the stability issue?

Appreciate any help.
Many thanks
Mickey

Have you accidentally installed the OH embedded MQTT broker as well as Mosquitto?

installing mosquitto on HO 1.4.1 can cause the conflict?

will try uninstalling. is there any additional configuration files which need to be changed?

Actually, if you already have mosquitto available, I would use that broker instead of the builtin one. That way, you can always start / stop / modify your openHAB installation and keep all the other pieces of software which rely on the MQTT broker still running.

One question: Is the MQTT Topic of your Tasmotas always “sonoff” ?

i’m not using the builtin. only the mosquitto.
but still having this conflict.

will try new full installation.

only for this device.

tried also different custom esphome bin file with the mqtt and its working great. immediate response time.

Ok. Than this can not be a problem.
How have you adressed your MQTT-Host ? As alias (openhabianpi) or direct via IP-Adress ?
In my setup this was a problem, when using the alias.

Edit:
When comparing your Tasmota-Setup with mine, there are two more different points.

  1. Somewhere in the docs of Theo Arends I wrote that the 2.3 core version is not as fast as 2.4.2.
  2. I have activated the Belkin WeMo inmy settings

Has this “address already in use” gone away now?

as IP address

Gone away only after flashing with new firmware instead tasmota. can’t understand why or what was wrong with the previous configuration.

My gut says duplicate IP address or device name

1 Like

I’m thinking what Rossko says is ok. Sorry I’m using Belkin-Emulation for Alexa (without Amazon-Binding).