Mosquitto


(João Curado) #1

I was trying to install a Sonoff-Tasmota controller and cannot install mosquitto on my OpenHab 2.3. I went to Openhabian config, update and tried to install mosquitto from Optional Components. I got this error :

The following packages have unmet dependencies:
mosquitto : Depends: libssl1.0.0 (>= 1.0.0) but it is not installable
Depends: libwebsockets3 (>= 1.2) but it is not installable
mosquitto-clients : Depends: libmosquitto1 (= 1.5-0mosquitto2~jessie1) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
FAILED

I could make a fresh install but I would like to use this one if possible.

What did I do wrong?

Thank you


(Richard ) #2

Is your device able to connect to the repository of the dependencies?


(Vincent Regaud) #3

try:

sudo apt-get -f install mosquitto

(João Curado) #4

I got the same result:

[21:36:04] openhabian@openHABianPi:~$ sudo apt-get -f install mosquitto
[sudo] password for openhabian:
Reading package lists… Done
Building dependency tree
Reading state information… Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
mosquitto : Depends: libssl1.0.0 (>= 1.0.0) but it is not installable
Depends: libwebsockets3 (>= 1.2) but it is not installable
E: Unable to correct problems, you have held broken packages.


(Vincent Regaud) #5

Next step:

sudo apt-get -u dist-upgrade

(João Curado) #6

[21:36:33] openhabian@openHABianPi:~$ sudo apt-get -u dist-upgrade
Reading package lists… Done
Building dependency tree
Reading state information… Done
Calculating upgrade… Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
[21:48:37] openhabian@openHABianPi:~$


(Vincent Regaud) #7
sudo apt-get install -f mosquitto

If that doesn’t work, I don’t know…
Your system is a bit broken. I am sure there are ways to fix it but it won’t be simple
Google will be your friend


(João Curado) #8

Thank you for your help

I think i found something to do tomorrow night (I’m busy tonight): a new fresh install of OH :slight_smile:

João