Motion detection not working on Fibaro Motion sensor

I’m new on this forum but have red many thread, already.
My system RB pi3+ + openHabian + openhab2.4.
I’m setting up my zwave on openhab with a Fibaro Motion Sensor FGMS001 FW 3.3 EU.
I have a Aeon labs Zstick S2 latest firmare (old one not Gen5) and I think I don’t recieve motion detection information.
It worked once just after device inclusion, linked to a simple rule:
rule “My 1st Rule”
Item Terrace_MotionAlarm received update
But now I do not receive events or Zwave logs (I’ve put Zwave in debug mode) when there is a movement, but the “eye” is blinking.

I’ve tryed to reset/reinclude the sensor, but that did not change anything (now I have 2 sensors on my network, because I miss somthing in exclution)
I put the polling interval to 1Hour and I get luminance information every 1 hour (that’s poor for what I want to do, but that’s an other issue), so the device is working.

Any clue, to what to search, device config ?
I saw many thread about this sensor but, it talks about inrecognized device, that’s not my case.

thanks for reading

Welcome to openHab.

I’ve had problems with this sensor as well. See posting here

(Fibaro motion sensor FGMS001 Gen5 (Zwaveplus))

I eventually replaced with another sensor. Moved the Fibaro out to the balcony. Did a full factory reset, included it back into network, named it and then changed no other settings. It appears the changing of settings was causing it to drop out of the network.

Thanks for your reply.
Do you mean that I have to remove the sensor from my network, then reset it and include again.
But If I update the sensor conf from paperUI then the sensor will fail again?

I reply to misself:
Some I’ve delete the node from network, then do a factory reset of the sensor, thne reinclude it.
it has been working for 2 hours.
During this period, motion detection rules and light sensor were correctly running.
But now it is not more working, event after pressing B button to wake up the sensor.
I don’t know what to do ? the device is going to sleep mode? is that a compatiblity issue with my Z-Wave old generation ?
there is no more log in openhab.log about this node when motion is detected.

New myself and it does take a bit of work to find your directions.

If you put openHab zwave in debug you can see the messages and can tell if it is the Fibaro that has issues or a setup. I have a few of these working on openHab so it must be something that can be fixed.

The log viewer is good.

It sounds like the lifeline association is not set but that is odd. The UI does not help because sometimes you can not see that it is set but it is there and working. The log will allow you to confirm.


2.4 loses associations. 2.5M1 forces the lifeline to workaround the issue. Do not use Paper UI for zwave or configuration parameters will all be set after modifying just one, and possibly other bad things like losing associations… use Habmin.

1 Like

Ok, to use Habmin to setup my sensor.
2.5M1? you mean it’s openhab 2.5M1 or zwave binding version? I’ve not yet updated openhab nor binding.
Like I said I’m new and have just take last stable openhabian image for Rb PI.
I’m trying to get logs, but facing autentication issues on my win10 Pro computer (while it’s working on Win10 family laptop ???)
Edit: I get logs with WinSCP: I don’t see any error. node is included arround 5:30PM, then I have a configuration update few minutes later (I think when I’ve set the location of the thing), node is reporting luminance motion alarm etc until 7:19PM and then no more at 7:28PM a “RX REQ ApplicationCommandHandler WAKE_UP_NOTIFICATION” followed by many “TX REQ SendData 149 ASSOCIATION_REMOVE GROUP_5 empty” and “RX RES SendData 149 ACCEPTED BY CONTROLLER”.
Does that mean that at 7:28PM all associations for this node were removed, and that’s why it do not work any more?

I keep you informed of what I’ve done:
-exclude sensor (again)
-factory reset
-added thing with Habmin (not with paper UI)
All seem to work fine for 3 days now, except one thing: hte device configuration, I don’t realy know if it’s updated. because when I change it it stay in “pending” or “waiting” state for hours in Habin interface.

That’s because it’s a battery-powered device, which will not be sent any config changes until the device wakes up. The frequency with which it wakes up depends on what you have set in the thing config. Remember, though, if you decide to change the wake up interval, you need to wait for a wake up cycle for the new wake up interval to be sent to the device. :wink:

Ok, thanks for your reply, default wake up is 7200, so 2hours max for pushing the config.

Edit: How do I put solved? just edit title and put [Solved] flag?

Check the checkbox (I forget what it’s called and it only shows up if you’re the OP) on the post that solved the issue for you.

Thanks I didn’t notice that little checkbox before