Motion sensor hsm100 fail to initialise

zwave
Tags: #<Tag:0x00007f51f2da3220>

(Avner) #203

@chris, I want to reduce the “on time” (parameter 2) from 20 min (the default value) to e.g. 3 min to test motion alarms going on/off.
In PaperUI, the save button is always disabled. How can I persist the new value?
Would I need to wake up the device?


(RayBe) #204

Did you try it from HABmin? I did encounter such behavior too from another device, @chris maybe a bug?


(Chris Jackson) #205

The usual reason for this is that PaperUI checks that parameters are within limits - presumably something is out of bounds.


(RayBe) #206

@chris, @Avner, do you guys also experience the behavior that sometimes HABmin states that the controller can’t communicate with HSM100 device? Restarting the binding solves the problem.
I am not sure if its the binding (dev-binding) or if its the device.
One of my HSM100 (mains powered) is 10 cm away from the controller!

On another note, whats your experience so far with the device and the dev-binding?

br,
Raymond


(Chris Jackson) #207

What do you mean exactly - can you show me the screenshot? It might be that the controller is reporting the device as failed - this is something I need to look at, but it’s not at the top of the list just yet.

I’m not using the device (it’s all packed up awaiting it’s call to go home :wink: ).


(Avner) #208

I was able to set the device to

  • on-time (parameter 2) - 3 min
  • polling-time - 10 min
    With these settings I was hoping to see on/off every 3 min (or every ~10 min since it was mentioned here that triggering an off/on event be a combination of both the polling-time and the on-time) but I did not see such events.
    The log file shows a Queue full error on the zwave thread (note1) so maybe the missing events problem is not related to specifically to the device this time (I’ll add another device and check if the missing events were specific to the device or due to a more general zwave problem).
    @chris, do you know what could cause the Queue full error on the zwave thread?

– note1 - Queue full error on the zwave thread

cat /var/log/openhab2/openhab.log
...
2017-04-17 05:43:28.805 [ERROR] [WaveSerialHandler$ZWaveReceiveThread] - Exception during ZWave thread. 
java.lang.IllegalStateException: Queue full
	at java.util.AbstractQueue.add(AbstractQueue.java:98)[:1.8.0_121]
	at java.util.concurrent.ArrayBlockingQueue.add(ArrayBlockingQueue.java:312)[:1.8.0_121]
	at org.openhab.binding.zwave.internal.protocol.ZWaveTransactionManager.processReceiveMessage(ZWaveTransactionManager.java:345)[200:org.openhab.binding.zwave:2.1.0.201704162057]
	at org.openhab.binding.zwave.internal.protocol.ZWaveController.incomingPacket(ZWaveController.java:1215)[200:org.openhab.binding.zwave:2.1.0.201704162057]
	at org.openhab.binding.zwave.handler.ZWaveControllerHandler.incomingMessage(ZWaveControllerHandler.java:636)[200:org.openhab.binding.zwave:2.1.0.201704162057]
	at org.openhab.binding.zwave.handler.ZWaveSerialHandler$ZWaveReceiveThread.run(ZWaveSerialHandler.java:320)[200:org.openhab.binding.zwave:2.1.0.201704162057]

Queue full exception during ZWave thread
(RayBe) #209

Its working atm, when it happens again i will make a screenshot.


(Avner) #210

I added another device and so far I get events every ~3 min from the HSM100 (as well as from the other device), so I think that the missing events, reported in here were due to the more general Queue full error on the zwave thread (and not because of the HSM100 device.

Based on the last tests, I think the device is performing ok now.
@chris, can you briefly explain the changes and point to the git revision, so I can learn something from this 6 months ordeal (even if this is a minor database change)?
Again, thanks for the time and effort that you put into it.


(Chris Jackson) #211

All I did was to add the extra command class removals into the database for the classes that needed to be removed. I’m not sure I can find a single PR as it’s in the development branch and is just a database change.


(RayBe) #212

@Avner So this is working ok now?

On both my sensors i get motion detected and values for lumi and temp.
I think its safe to say that everything is working as it should, what do you guys think @chris, @Avner?

As a note: i just updated the device parameter descriptions so they show up nicely and do not trow a error on the database site :slight_smile:


(Avner) #213

I think so. I still have this problem, where after a while zwave events stop coming up, and then I get a Queue Full exception error.
I connected another device and when this happened, I stopped seeing events from the other device as well, so I think this is a more general problem that is related to the zwave thread and not specifically to the HSM100.
I opened another thread for this issue here. @chris do you know what could cause the exception?


(Chris Jackson) #214

Not off the top of my head - I’d need to look, but I can probably be pretty sure it’s nothing to do with this device.


(Avner) #215

Just to be sure, I restarted openhab with the other device only (took the batteries from the HSM100), to see if the Queue Full assertion error still happens, when the HSM100 is not active. So far openhab runs without problem. I’ll keep monitoring…
@chris I read that if other dead nodes (of devices that no longer exist) on the zwave stick can create side effects. Is there a way to remove them without resetting the stick?


(Chris Jackson) #216

I doubt that this is related to the HSM100, but if it is, then you’d be better to put the batteries back in and get a log showing the problem. Getting a log that doesn’t show the problem isn’t going to be useful.


(Avner) #217

Ok, I put the batteries back on. Attached are the log files:
zwave.log (with DEBUG enabled)
openhab.log
events.log

This time, there is no Queue Full exception error, but the events still stop after some time.
The flow of events is in note1.
I’m working with a stable build, and the development zwave binding on top. I added the development binding using the steps in note2 (Should I do it differently?)


note1 - flow of events

  • Started openhab at around 2017-05-06 08:54

  • OFF/ON events coming from the HASM100 and Fibaro devices at e.g.
    – node6 (Fibaro): 2017-05-06 09:01:06.496, 2017-05-06 09:12:10.579
    – node3 (HSM100): 2017-05-06 09:01:46.219, 2017-05-06 09:12:10.270

  • Communication error events
    – node3 (HSM100): 2017-05-06 13:14:44.666
    – node6 (Fibaro): 2017-05-06 14:48:28.029


note2 - installed bundles

uninstall zwave binding from http://localhost:8080/paperui/index.html#/extensions
cd /usr/share/openhab2/addons
sudo wget http://www.cd-jackson.com/downloads/openhab2/org.openhab.binding.zwave-2.1.0-SNAPSHOT.jar
sudo chown openhab:openhab org.openhab.binding.zwave-2.1.0-SNAPSHOT.jar

openhab> bundle:list -s | grep zwave
200 | Active    |  80 | 2.1.0.201704162057    | ZWave Binding                                          | org.openhab.binding.zwave
202 | Installed |  80 | 2.0.0                 | ZWave Binding                                          | org.openhab.binding.zwave

Queue full exception during ZWave thread
(Chris Jackson) #218

Sorry - but unless it’s a debug log, it’s really of no use.

Also, there are other errors in your file - you are trying to load two zwave bundles so you should also resolve this so you know what version is actually running.


(Avner) #219

It is a debug log. Can you please take a look?

I described in here how the development binding was loaded on top of the stable version. Doesn’t status Active for the development binding (2.1.0.201704162057) indicate that this is the version that is running. please let me know how to install the development version on top of a stable OpenHab2, if my development installation steps are not correct.


(Chris Jackson) #220

Sorry - my point was that it isn’t a debug log (unless you updated it today?).


(Avner) #221

It is a debug log


(Chris Jackson) #222

Ok - so you updated it today then?