Moving Gen5 Z Stick from Pi to Debian

zwave
Tags: #<Tag:0x00007f014b940f68>

(Thomas Moulton) #1
  • Platform information:
    • Hardware: i3/16MB/4TB
    • OS: Debian 9
    • Java Runtime Environment: java version “1.8.0_191”
    • openHAB version: 2.4 (New Install)
  • Issue of the topic: I a moving my Z Stick from PI to Debian, stays offline

2019-01-11 13:54:56.036 [INFO ] [b.core.service.AbstractActiveService] - AlarmDecoder binding has been started
2019-01-11 13:54:56.044 [INFO ] [decoder.internal.AlarmDecoderBinding] - connected to 192.168.8.10:10000
2019-01-11 14:11:25.203 [INFO ] [ternal.dhcp.DHCPPacketListenerServer] - DHCP request packet listener online
2019-01-11 14:19:09.637 [INFO ] [ing.zwave.handler.ZWaveSerialHandler] - Connecting to serial port ‘/dev/ttyACM0’
2019-01-11 14:23:46.762 [INFO ] [ing.zwave.handler.ZWaveSerialHandler] - Connecting to serial port ‘/dev/ttyACM0’
2019-01-11 14:23:57.066 [INFO ] [ing.zwave.handler.ZWaveSerialHandler] - Stopped ZWave serial handler
2019-01-11 14:25:22.495 [INFO ] [ing.zwave.handler.ZWaveSerialHandler] - Stopped ZWave serial handler
2019-01-11 14:25:22.499 [INFO ] [ing.zwave.handler.ZWaveSerialHandler] - Connecting to serial port ‘/dev/ttyACM0’

Shows OFFLINE - Communications Error

Above I remove and reinstall USB Stick

Other threads say it should just work…

Do I need to reset the config of the z stick?

Tom


(SiHui) #2

Definitely no (if you are thinking about a hard reset).

Double check https://www.openhab.org/docs/installation/linux.html#privileges-for-common-peripherals


(Thomas Moulton) #3

This was my second attempt… I did all that and did an apt-get purge to start over…

fixed, thanks