Moving to Insteon Binding for OpenHAB 3

Hey guys, got a couple quick questions on migrating my Insteon configuration to OH3 (think I’m on 3.0.1 stable). First question is I just want to confirm that the poll interval is in seconds and that the “recommended” value is 300? I had this configured in my things file as

Bridge insteon:network:home [port="/hub2/xxxx:xxxx@192.168.xxx.xxx:25105,poll_time=1000"] 

I was pretty sure the interval was measured in milliseconds, and that’s a pretty big jump from 1 second to 300 seconds as the recommendation.

Second question is, now that I’m moving away from file-based configurations, how do I add channels for broadcasting Scene updates? I’ve created the Hub as both a Bridge and a Device and the Channels tab is empty, assuming I’m supposed to add via code, but I’m not sure of the syntax. Anyone got any examples they could post?

Yes, poll interval for Insteon devices is now in seconds, and you don’t need to configure if you want to use the default of 300 seconds. The OH 1 binding used milliseconds and the default was 300000 milliseconds which is 300 seconds.

As for setting up broadcast groups, you can set it with the deviceConfig parameter for your hub. See Direct Sending of Group Broadcasts (Triggering Scenes)

Hi Rob, thanks for the response, but I’m still unclear on how to translate the Group Broadcasts into the OH3 web interface. I had several broadcast channels set up for OH2.5 in my .things file, but the web interface seems less straightforward in this regard. I’m assuming I’ll have to add broadcasts via the “Code” tab, but does it get added on the “bridge” Thing or do I create a separate Thing for the hub itself? And what would be the syntax since it looks like the yaml is different for web-added Things?

UID: insteon:device:0a2ce300ab:516b34c737
label: Insteon Hub
thingTypeUID: insteon:device
configuration:
  productKey: "0x000045"
  address: XX.XX.XX
bridgeUID: insteon:network:0a2ce300ab
location: Master Bedroom

You configure it on the bottom of the Thing tab:

Ah, perfect, that was the missing piece. Thanks Rob!

For anyone else who’s as slow as I am on the uptake here, I entered

{'broadcastGroups': [1,2]}

into the “Device Configuration” entry. After several seconds, two “broadcastOnOff” channels appeared in my hub’s Channel tab and I was able to add them as normal to the model.

1 Like

I’m completely new to Openhab and I’m starting with OH3. I have my zwave stick working as well as my Sonos network and my hue lights, but I’m stumped with getting my insteon plm to recognize my X10 devices. I’ve tried creating both Thing and item files defining an insteon bridge and the X10 devices. All of the things and items have successfully initiated and show with the green “online” labels, but when I add am X10 dimming module (item) to the Model (and adjust the dimmer slider to 100%), no signal is sent to the lamp. I saw the above reference to using the Device configuration option instead of the .item and .thing files but I have no idea what syntax to use here to define the X10 devices.

Check out Problem with X10 on Insteon binding, that will hopefully help you figure out your problems. If not, maybe @isabellep can provide some insight.