Moving toward Z-wave and Zigbee

Yes, they work with the ZigBee binding. They are a bit problematic due to the way they work, but that’s certainly not a regional issue as per your statement above.

Many people are using Xiaomi devices with the ZigBee binding - on the other hand, others have problems with getting them working well, but again, it’s not a regional issue in any way,

How do I get something added to the database.

I just looked here, and don’t see the GE 14297 Fan Controller on the list.

This is a community maintained database. The guide is here.
What is required us the xml file generated by OpenHAB along with a pdf of the user guide and an image.
Either you can then add it or somebody else here can do that.

After the entry is approved, the database is uploaded to GitHub once or twice week. The database then gets picked up bu the build process into a snapshot zwave binding. You are then able to update just that binding, if needed.

I’m completely stuck trying to install the HUSBZB-1 stick. Trying to search for the Zigbee or Z-wave stick gives me nothing at all. I’ve verified that /dev/ttyUSB0 and 1 exist and dmesg shows that the two ports were added when I plugged in the stick.

Here is what I’ve done:
Plugged stick into USB port
Added openhab to tty group and put in the extra JAVA options and added the serial binding as noted here.
Confirmed that OS sees the stick
Added Zigbee and Z-wave bindings in PaperUI
Went to Inbox and “Search or things”, selected “Z-Wave Binding” and then “Z-wave serial Controller” and set the serial port to /dev/USB0. It creates the thing, but it says “OFFLINE - COMMUNICATION ERROR”
Tried adding is as a zigbee stick using manual and selecting the Ember EM35x Coordinator and setting it up like the picture here. Also communication error.

Am I missing a step?

You should be able to select it from the dropdown and it is usually /dev/ttyUSB0


Maybe it is related with this:

Only needed for Zigbee, not Z-Wave

I just did it, you got everything right
maybe restart openhab if you haven’t otherwise, relax, it takes a few minutes

1 Like

What do you mean by this?

The ZWave binding doesn’t support searching for sticks at all - you must manually add the stick. I’m also not sure if the ZigBee binding will do this either - the USB search doesn’t work on all operating systems, and probably won’t work for all sticks. Just do this manually.

It shouldn’t be required for ZigBee either if using the Snapshot.

1 Like

There is no dropdown - but that’s a typo in my original message. I did set it to /dev/ttyUSB0. It’s just a text box to type the serial port into.

Note that when I click through to the Z-wave Serial controller it gives additional error information:

Serial Error: Port {0} does not exist

As mentioned, I’ve confirmed that /dev/ttyUSB0 and 1 exist. They are not there when the stick is not plugged in, and they appear once the stick has been plugged in.

I tried a restart. Same behavior.

If I do a search for new things, I don’t get anything automatically detected. Maybe I should’t have expected that. So I did add the stick manually for both Z-wave and Zigbee; but both show communication error.

I installed the bindings using PaperUI - what do I have to do differently to “use the Snapshot”?

There is a dropdown in PaperUI and HABmin for me. I think occasionally I have needed to restart OpenHAB to get the dropdown to show though.
I think missing the dropdown is an indication that OH has not detected the serial ports.

I unplugged the stick, uninstalled the Zigbee binding, then re-installed Zigbee and plugged the stick back in. Same behavior.

I’ve restarted multiple times and nothing. I am still running 2.4 - do I need to upgrade to 2.5 (milestone or snapshot)?

I think Milestone 6 is scheduled to be released today and the stable 2.5 in two weeks.

Is 2.5 required to get this stick working, or should it be working with 2.4?

It should work fine with 2.4. Your problems are not with the binding - not being able to open the ports is a more fundamental issue and the binding doesn’t interact directly with the serial driver anyway.

Unfortunately I’m not sure what else to suggest if you’ve done all the standard stuff (permissions, command line parameters etc) which I think is the case from a quick scan of the above.

1 Like

Ugh! I went back through everything and apparently I forgot the step of adding openhab to the dialout group. Now I can see the controller.

Next hurdle: I don’t see any Zwave devices although I installed 2 new devices (one on the list of supported devices and one not) yesterday. One is a GE branded fan controller, and the other is a GE branded light switch. I also have several Hue devices, none of which are showing up when I search for Zigbee devices.

What now?

Described what you mean by “installed”. How did you pair the devices to the controller?

Same for the Hue, how did you pair then to the controller?